summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:46:43 +0200
committerM0Rf302015-06-17 15:46:43 +0200
commit2d64149aba132001277c45512be794375089c9fd (patch)
treec9bdc015a856b175d2fd8df0d20b871c7aa63e5f
downloadaur-2d64149aba132001277c45512be794375089c9fd.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--kodi-addon-pulsar.install30
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a3782476ad6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kodi-addon-pulsar
+ pkgdesc = Pulsar is an torrent finding and streaming engine for Kodi
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/steeve/plugin.video.pulsar
+ install = kodi-addon-pulsar.install
+ arch = any
+ license = GPL3
+ depends = kodi
+ depends = kodi-standalone-service
+ noextract = plugin.video.pulsar-0.5.0.zip
+ options = !strip
+ source = https://github.com/steeve/plugin.video.pulsar/releases/download/v0.5.0/plugin.video.pulsar-0.5.0.zip
+ md5sums = af05e3acf9e49547c680e14cc5a8d43b
+
+pkgname = kodi-addon-pulsar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..311136a7a11a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: M0Rf30
+
+pkgname=kodi-addon-pulsar
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Pulsar is an torrent finding and streaming engine for Kodi'
+classname=plugin.video.pulsar
+arch=('any')
+url='https://github.com/steeve/plugin.video.pulsar'
+license=('GPL3')
+depends=('kodi' 'kodi-standalone-service')
+options=(!strip)
+noextract=(${classname}-${pkgver}.zip)
+source=("https://github.com/steeve/plugin.video.pulsar/releases/download/v${pkgver}/${classname}-${pkgver}.zip")
+install=kodi-addon-pulsar.install
+installpath=/var/lib/kodi/.kodi/addons/
+
+package() {
+ mkdir -p ${pkgdir}/${installpath}
+ unzip -o ${classname}-${pkgver}.zip -d ${pkgdir}/${installpath}
+ rm ${pkgdir}/${installpath}/${classname}/Makefile
+ rm -r ${pkgdir}/${installpath}/${classname}/resources/bin/{windows_x86,darwin_x64,linux_arm}
+}
+
+md5sums=('af05e3acf9e49547c680e14cc5a8d43b')
diff --git a/kodi-addon-pulsar.install b/kodi-addon-pulsar.install
new file mode 100644
index 000000000000..689f2b1e6fc6
--- /dev/null
+++ b/kodi-addon-pulsar.install
@@ -0,0 +1,30 @@
+classname=plugin.video.pulsar
+usr=420
+home=/var/lib/kodi/.kodi/addons
+repo=$home/repository.pulsar
+addonpath=$home/${classname}
+
+_chown() {
+ chmod 755 $(find $addonpath -type d)
+ chmod 644 $(find $addonpath -type f)
+ chown -R $usr:$usr $home $addonpath
+}
+
+## arg 1: the new package version
+post_install() {
+ getent passwd $usr &> /dev/null || useradd -r -d $home -s /bin/bash $usr
+ _chown
+
+}
+
+post_upgrade() {
+ _chown
+}
+
+## arg 1: the old package version
+post_remove() {
+ rm -r $addonpath $repo
+ return 0
+}
+
+# vim:set ts=2 sw=2 et: