summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelleyMcChes2018-07-20 02:48:11 -0400
committerKelleyMcChes2018-07-20 02:48:11 -0400
commit2dafbe93b175789e01a9efec37950351576a8534 (patch)
treea20d2e8daf2cbfd00914ffc9761b707f69c04827
parent28924dd3fc022ab973e6766fd08f0acc2db256ad (diff)
downloadaur-2dafbe93b175789e01a9efec37950351576a8534.tar.gz
Updated howdy to 2.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD38
2 files changed, 18 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecff4b664d61..02159dd30627 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = howdy
pkgdesc = Windows Hello for Linux
- pkgver = 2.2.2
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/boltgolt/howdy
arch = x86_64
@@ -14,13 +14,16 @@ pkgbase = howdy
depends = hdf5
depends = python2
depends = python3
- optdepends = gedit: configuration support
+ depends = python-pillow
+ depends = python-face_recognition_models
+ depends = python-click
+ depends = python-numpy
backup = usr/lib/security/howdy/config.ini
- source = https://github.com/boltgolt/howdy/archive/v2.2.2.tar.gz
+ source = https://github.com/boltgolt/howdy/archive/v2.3.0.tar.gz
source = https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.6-1/pam-python-1.0.6.tar.gz
source = https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-fedora.patch
source = https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-gcc8.patch
- sha256sums = d88e567733fdedc9de1c4b9c5db9ebf91f1940fe3ca93e84e5cd31c614b2542c
+ sha256sums = 3dd45d7a5aaf5af2b27e935374f4f233b41b11379fd6bfad5e93b397689ab57a
sha256sums = 0ef4dda35da14088afb1640266415730a6e0274bea934917beb5aca90318f853
sha256sums = acb9d1b5cf7cad73d5524334b7954431bb9b90f960980378c538907e468c34b5
sha256sums = 02dd9a4d8ec921ff9a2408183f290f08102e3f9e0151786ae7220a4d550bfe24
diff --git a/PKGBUILD b/PKGBUILD
index e65fe2cdc10a..2c262412e91e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: boltgolt <boltgolt@gmail.com>
# Maintainer: Kelley McChesney <kelley@kelleymcchesney.us>
pkgname=howdy
-pkgver=2.2.2
+pkgver=2.3.0
pkgrel=1
-epoch=
pkgdesc="Windows Hello for Linux"
arch=('x86_64')
url="https://github.com/boltgolt/howdy"
@@ -13,6 +12,10 @@ depends=(
'hdf5'
'python2'
'python3'
+ 'python-pillow'
+ 'python-face_recognition_models'
+ 'python-click'
+ 'python-numpy'
)
makedepends=(
'python2-sphinx'
@@ -21,27 +24,15 @@ makedepends=(
'pkgfile'
'python-pip'
)
-checkdepends=()
-optdepends=('gedit: configuration support')
-provides=()
-conflicts=()
-replaces=()
backup=('usr/lib/security/howdy/config.ini')
-options=()
-install=
-changelog=
-source=("https://github.com/boltgolt/howdy/archive/v2.2.2.tar.gz"
+source=("https://github.com/boltgolt/howdy/archive/v2.3.0.tar.gz"
"https://downloads.sourceforge.net/project/pam-python/pam-python-1.0.6-1/pam-python-1.0.6.tar.gz"
"https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-fedora.patch"
"https://sourceforge.net/p/pam-python/tickets/_discuss/thread/5dc8cfd5/5839/attachment/pam-python-1.0.6-gcc8.patch")
-sha256sums=('d88e567733fdedc9de1c4b9c5db9ebf91f1940fe3ca93e84e5cd31c614b2542c'
+sha256sums=('3dd45d7a5aaf5af2b27e935374f4f233b41b11379fd6bfad5e93b397689ab57a'
'0ef4dda35da14088afb1640266415730a6e0274bea934917beb5aca90318f853'
'acb9d1b5cf7cad73d5524334b7954431bb9b90f960980378c538907e468c34b5'
'02dd9a4d8ec921ff9a2408183f290f08102e3f9e0151786ae7220a4d550bfe24')
-noextract=()
-md5sums=()
-validpgpkeys=()
-
prepare() {
# Preparing dlib with GPU here
git clone --depth 1 https://github.com/davisking/dlib.git dlib_clone
@@ -58,8 +49,8 @@ prepare() {
# Doing some fixes for pam-python so that it can compile
sudo pkgfile -u
sudo pkgfile /usr/include/sys/cdefs.h core/glibc
+ cd ..
}
-
build() {
# Building pam-python
cd pam-python-1.0.6
@@ -70,16 +61,8 @@ build() {
cd dlib_clone
python setup.py build
}
-
package() {
- # Installing pip packages
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed face_recognition_models==0.3.0 Click>=6.0 numpy Pillow
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps --no-warn-script-location face_recognition==1.2.2
- python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/click"
- python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/face_recognition_models"
- python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/numpy"
- python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/PIL"
- python -O -m compileall "${pkgdir}/usr/lib/python3.6/site-packages/face_recognition"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps face_recognition
# Installing dlib with GPU
cd dlib_clone
@@ -92,11 +75,12 @@ package() {
cd ..
# Installing the proper license files and the rest of howdy
- cd howdy-2.2.2
+ cd howdy-2.3.0
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
mkdir -p "$pkgdir/usr/lib/security/howdy"
cp -r src/* "$pkgdir/usr/lib/security/howdy"
chmod 600 -R "$pkgdir/usr/lib/security/howdy"
+ mkdir -p "$pkgdir/usr/bin"
ln -s /lib/security/howdy/cli.py "$pkgdir/usr/bin/howdy"
chmod +x "$pkgdir/usr/lib/security/howdy/cli.py"
mkdir -p "$pkgdir/usr/share/bash-completion/completions"