summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilip Parag2020-09-04 21:03:35 +0200
committerFilip Parag2020-09-04 21:03:35 +0200
commit2deb03da3a430781956d57b1dc24604007f45dc7 (patch)
tree4b17c206fef96d640d737d362771e33a377d5b2c
parent76b62b919116f583442df632e32fc1b0590e4fd6 (diff)
downloadaur-2deb03da3a430781956d57b1dc24604007f45dc7.tar.gz
version 2.11.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b59a4d203d43..948f794de945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = wikiman
pkgdesc = Offline search engine for manual pages, Arch Wiki, Gentoo Wiki and other documentation.
- pkgver = 2.11
+ pkgver = 2.11.1
pkgrel = 1
url = https://github.com/filiparag/wikiman
arch = any
license = MIT
+ makedepends = make
depends = man
depends = fzf
depends = ripgrep
depends = awk
depends = w3m
+ depends = findutils
optdepends = arch-wiki-docs: enable Arch Wiki
backup = etc/wikiman.conf
- source = wikiman-2.11.tar.gz::https://github.com/filiparag/wikiman/archive/2.11.tar.gz
- sha256sums = cfb85d033c6a91226d655cbfa95ae857be51b9b14151112ca1ac6243c0b03960
+ source = wikiman-2.11.1.tar.gz::https://github.com/filiparag/wikiman/archive/2.11.1.tar.gz
+ sha256sums = 8c6302a1120286937c4f0718a43540e68b9aaed64d76bfdbc1d1c5bc9e17671b
pkgname = wikiman
diff --git a/PKGBUILD b/PKGBUILD
index b75b943d431d..86071de08f25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer Filip Parag <aur@filiparag.com>
pkgname=wikiman
-pkgver=2.11
+pkgver=2.11.1
pkgrel=1
pkgdesc="Offline search engine for manual pages, Arch Wiki, Gentoo Wiki and other documentation."
arch=('any')
url="https://github.com/filiparag/wikiman"
license=('MIT')
-depends=('man' 'fzf' 'ripgrep' 'awk' 'w3m')
+makedepends=('make')
+depends=('man' 'fzf' 'ripgrep' 'awk' 'w3m' 'findutils')
+optdepends=('arch-wiki-docs: enable Arch Wiki')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('cfb85d033c6a91226d655cbfa95ae857be51b9b14151112ca1ac6243c0b03960')
+sha256sums=('8c6302a1120286937c4f0718a43540e68b9aaed64d76bfdbc1d1c5bc9e17671b')
backup=('etc/wikiman.conf')
-optdepends=('arch-wiki-docs: enable Arch Wiki')
package() {
cd "${pkgname}-${pkgver}"
- make
make prefix=${pkgdir} install
} \ No newline at end of file