summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-22 12:27:14 +0200
committerChristoph Fink2023-03-22 12:27:14 +0200
commit2df61f4a3e42e23b9d76054a27a47a5ab1185fa9 (patch)
tree3b276a719e779d4b01927a6266a2f76c60bf7f2d
parent3bd3add5fc1fc786f64a5b7b666d40068dd313c5 (diff)
downloadaur-2df61f4a3e42e23b9d76054a27a47a5ab1185fa9.tar.gz
Initial upload: r-anytime 0.3.9-1
Initial upload: r-asciicast 2.3.0-1 Initial upload: r-decor 1.0.1-1 Initial upload: r-distro 0.1.0-1 Initial upload: r-gettz 0.0.5-1 Initial upload: r-pak 0.4.0-1 Initial upload: r-parsedate 1.3.1-1 Initial upload: r-pkgcache 2.0.4-1 Initial upload: r-pkgdepends 0.4.0-1 Initial upload: r-pkgsearch 3.1.2-1 upgpkg: r-pkgload 1.3.2-2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2cd3e122485..03516b8aedbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,20 @@
pkgbase = r-pkgload
pkgdesc = Simulate Package Installation and Attach
pkgver = 1.3.2
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=pkgload
arch = any
license = GPL3
+ checkdepends = r-bitops
+ checkdepends = r-covr
+ checkdepends = r-mathjaxr
+ checkdepends = r-mockr
+ checkdepends = r-pak
+ checkdepends = r-pkgbuild
+ checkdepends = r-rcpp
+ checkdepends = r-remotes
+ checkdepends = r-rstudioapi
+ checkdepends = r-testthat>=3.1.0
depends = r>=3.4.0
depends = r-cli>=3.3.0
depends = r-crayon
@@ -23,7 +33,6 @@ pkgbase = r-pkgload
optdepends = r-rcpp
optdepends = r-remotes
optdepends = r-rstudioapi
- optdepends = r-testthat>=3.1.0
source = https://cran.r-project.org/src/contrib/pkgload_1.3.2.tar.gz
b2sums = a6113732d047812744902e6fed558b6f7301dd27a970509ec30990853f4bfa9e46e9fd55be3314f8d70e4ddd481f09f0186f8a0f0c85d90bbc8231750443bbf3
diff --git a/PKGBUILD b/PKGBUILD
index db19c402fb79..b5f4591d588c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _cranname=pkgload
_cranver=1.3.2
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Simulate Package Installation and Attach"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
@@ -31,18 +31,28 @@ optdepends=(
"r-rcpp"
"r-remotes"
"r-rstudioapi"
+)
+checkdepends=(
+ "${optdepends[@]}"
"r-testthat>=3.1.0"
)
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("a6113732d047812744902e6fed558b6f7301dd27a970509ec30990853f4bfa9e46e9fd55be3314f8d70e4ddd481f09f0186f8a0f0c85d90bbc8231750443bbf3")
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p "${srcdir}/build/"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
+}
+
+check() {
+ cd "${srcdir}/${_cranname}/tests"
+ R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
}
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"