summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2024-04-15 10:38:14 +0200
committerRicardo Band2024-04-15 10:38:14 +0200
commit2e0561caf4fb220094e1c86d64a4a37fb3e12ca6 (patch)
treeac1270282ca03aa49afca5dc4b5e682ee895295d
parentbf9c362a9da8925908319376e9f9d9b0a2d4b8e2 (diff)
downloadaur-2e0561caf4fb220094e1c86d64a4a37fb3e12ca6.tar.gz
fix dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d0361b6fd9b..b26280fe2d99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
pkgver = 2.5.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/justinmayer/virtualfish
arch = any
license = custom:MIT
- makedepends = python-build
- makedepends = python-installer
- makedepends = python-wheel
+ makedepends = poetry-core
+ makedepends = python-installer
depends = fish
- depends = python
+ depends = python-packaging
+ depends = python-pkgconfig
+ depends = python-psutil
+ depends = python-virtualenv
source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.5.7.tar.gz
sha256sums = f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba
diff --git a/PKGBUILD b/PKGBUILD
index ba2ee9d40534..bb1e9cb4479f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.7
-pkgrel=2
+pkgrel=3
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("custom:MIT")
-depends=("fish" "python" ) #"python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
-makedepends=("python-build" "python-installer" "python-wheel") # "poetry-core")
+depends=("fish" "python-packaging" "python-pkgconfig" "python-psutil" "python-virtualenv")
+makedepends=("poetry-core" "python-installer")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('f507d8cd281cb1c1ebf6021fc18ac20a85d8afbfc5ea4fe8eb0a3f54349bc9ba')
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ poetry check
+}
+
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel #--no-isolation
+
+ poetry build --format wheel --output dist
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}