summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-08-17 10:42:25 +0800
committerwangjiezhe2016-08-17 10:42:25 +0800
commit2e4f98afef6698174e800c25108beafd50720ba2 (patch)
tree4d7d1b8248a72bbb25ac5322f7c10b892dd2b27c
downloadaur-2e4f98afef6698174e800c25108beafd50720ba2.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD68
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b7bb3af5871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Wed Aug 17 02:39:15 UTC 2016
+pkgbase = trilinos-git
+ pkgdesc = An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems.
+ pkgver = r71307.22496b4
+ pkgrel = 1
+ url = https://github.com/trilinos/Trilinos
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = python2
+ makedepends = python2-numpy
+ makedepends = swig
+ makedepends = gcc
+ makedepends = gcc-fortran
+ makedepends = openmpi
+ makedepends = perl
+ makedepends = blas
+ makedepends = lapack
+ makedepends = cmake
+ makedepends = libmatio
+ makedepends = netcdf
+ depends = lapack
+ depends = openmpi
+ depends = python2
+ depends = boost
+ provides = trilinos
+ conflicts = trilinos
+ conflicts = gtest
+ options = ccache
+ source = git+https://github.com/trilinos/Trilinos.git
+ md5sums = SKIP
+
+pkgname = trilinos-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc73cd18261b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*~
+\#*\#
+.\#*
+/pkg/
+/src/
+/Trilinos
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a343195269c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Myles English <myles at rockhead.biz>
+# Contributor: Feng Wang <wanng.fenng@gmail.com>
+# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+
+pkgname=trilinos-git
+_pkgname=Trilinos
+pkgver=r71307.22496b4
+pkgrel=1
+pkgdesc="An effort to develop algorithms and enabling technologies within an object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems."
+arch=('i686' 'x86_64')
+url="https://github.com/trilinos/Trilinos"
+license=('LGPL3')
+depends=('lapack' 'openmpi' 'python2' 'boost')
+provides=('trilinos')
+conflicts=('trilinos' 'gtest')
+source=(git+${url}.git)
+makedepends=('git' 'python2' 'python2-numpy' 'swig' 'gcc' 'gcc-fortran' 'openmpi' 'perl' 'blas' 'lapack' 'cmake' 'libmatio' 'netcdf')
+# gcc-fortran gcc-fortran-multilib
+md5sums=('SKIP')
+options=('ccache')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+
+ find ${srcdir}/${_pkgname} -name "*" -type f -exec \
+ sed -i 's#\(/usr/bin/env \|/usr/bin/\)python[2-3]*#\1python2#' {} \;
+
+ sed -i 's#SWIG_VERSION_CEILING 2.0.8#SWIG_VERSION_CEILING 3.0.2#' \
+ ${srcdir}/${_pkgname}/packages/PyTrilinos/CMakeLists.txt
+
+ [[ -e build ]] && rm -rf build
+ mkdir build
+ cd build
+
+ cmake .. \
+ -DTrilinos_ENABLE_ALL_PACKAGES:BOOL=ON \
+ -DTrilinos_ENABLE_FEI=OFF \
+ -DTrilinos_ENABLE_STKClassic=OFF \
+ -DTrilinos_ENABLE_SEACAS=ON \
+ -DTrilinos_ENABLE_Sundance=OFF \
+ -DTrilinos_ENABLE_TESTS=OFF \
+ -DTrilinos_ENABLE_OpenMP:BOOL=ON \
+ -DTPL_ENABLE_MPI:BOOL=ON \
+ -DTrilinos_ENABLE_PyTrilinos:BOOL=ON \
+ -DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/opt/trilinos \
+ -DTPL_ENABLE_Netcdf=ON \
+ -DTPL_ENABLE_QT=OFF \
+ -DTPL_ENABLE_GLM=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ $EXTRA_ARGS
+
+ make
+}
+
+package() {
+ cd $srcdir/${_pkgname}/build
+ make install DESTDIR=$pkgdir
+
+ mkdir -p "${pkgdir}/etc/profile.d"
+ echo "export TRILINOS_DIR=/opt/trilinos" > "${pkgdir}/etc/profile.d/trilinos.sh"
+ chmod +x "${pkgdir}/etc/profile.d/trilinos.sh"
+}