summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Astrachan2020-11-19 15:10:19 -0500
committerWinston Astrachan2020-11-19 15:10:19 -0500
commit2e54380daa239470ba04f69384f10cffc3e44352 (patch)
treef7a83f02ad0ed66417f2db05a733d6ae5f72b61f
parentffc5c7ffcf4b239040f60360a7e7ac8ed5820336 (diff)
downloadaur-2e54380daa239470ba04f69384f10cffc3e44352.tar.gz
upgpkg: git-secret 0.3.3-1
upstream release maint: update git-secret
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD10
4 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00b434fc325a..1e0b43b71b89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = git-secret
pkgdesc = A bash-tool to store your private data inside a git repository
- pkgver = 0.3.2
- pkgrel = 2
+ pkgver = 0.3.3
+ pkgrel = 1
url = https://github.com/sobolevn/git-secret/
arch = any
license = MIT
makedepends = ruby-ronn
depends = git
depends = gnupg
- source = LICENSE
- source = git-secret-0.3.2::https://github.com/sobolevn/git-secret/archive/v0.3.2.tar.gz
- sha256sums = 6d4b9636df66066960e535a499484a7b334f1b362547be5314349d66fe588b05
- sha256sums = 07b32b096e5ff5b4818096b1858c1f69df4684bb0f256e620514cf88f44ded85
+ source = LICENSE::https://raw.githubusercontent.com/sobolevn/git-secret/v0.3.3/LICENSE.md
+ source = git-secret-0.3.3::https://github.com/sobolevn/git-secret/archive/v0.3.3.tar.gz
+ sha256sums = bc950a06cb1ba74afe4815dadb2f9e4639542de2894c6838924676981672d483
+ sha256sums = d8c19a5cbd174e95484a4233605985dd3b060a8a83d14d41c3bad1d534c6ab39
pkgname = git-secret
diff --git a/.gitignore b/.gitignore
index 3a3b8afcbb89..ae7b2948b37f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ git-secret-*
pkg
src
*.orig
+LICENSE
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 6d833c960217..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,9 +0,0 @@
-MIT License
-
-Copyright (c) 2016 Nikita Sobolev
-
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 5c29711207a4..1cba596605cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Ibrahim Tunali <ibrahimtunali at gmail dot com>
pkgname=git-secret
-pkgver=0.3.2
-pkgrel=2
+pkgver=0.3.3
+pkgrel=1
pkgdesc='A bash-tool to store your private data inside a git repository'
arch=('any')
url='https://github.com/sobolevn/git-secret/'
license=('MIT')
depends=('git' 'gnupg')
makedepends=('ruby-ronn')
-source=('LICENSE'
+source=("LICENSE::https://raw.githubusercontent.com/sobolevn/git-secret/v${pkgver}/LICENSE.md"
"${pkgname}-${pkgver}::https://github.com/sobolevn/git-secret/archive/v${pkgver}.tar.gz"
)
-sha256sums=('6d4b9636df66066960e535a499484a7b334f1b362547be5314349d66fe588b05'
- '07b32b096e5ff5b4818096b1858c1f69df4684bb0f256e620514cf88f44ded85'
+sha256sums=('bc950a06cb1ba74afe4815dadb2f9e4639542de2894c6838924676981672d483'
+ 'd8c19a5cbd174e95484a4233605985dd3b060a8a83d14d41c3bad1d534c6ab39'
)
build() {