summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThunderMikey2020-12-05 17:37:27 +0000
committerThunderMikey2020-12-05 17:37:27 +0000
commit2e9b3151035c97073d1d47caef42e7d3994719e6 (patch)
tree45933bb23a89e6ee0926a6e7e8269057d375c272
downloadaur-2e9b3151035c97073d1d47caef42e7d3994719e6.tar.gz
init commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bc2d3a7c164
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lifxlan-git
+ pkgdesc = Python library for accessing LIFX devices locally using the official LIFX LAN protocol
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://github.com/mclarkk/lifxlan
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-requests
+ depends = python-setuptools
+ depends = python-bitstring
+ depends = python-netifaces
+ provides = lifxlan
+ source = lifxlan::git+https://github.com/mclarkk/lifxlan.git
+ md5sums = SKIP
+
+pkgname = lifxlan-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc85b09b55af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: ThunderMikey
+
+pkgname=lifxlan-git
+_pkgname="lifxlan"
+pkgver=386.ba51118
+pkgrel=1
+pkgdesc="Python library for accessing LIFX devices locally using the official LIFX LAN protocol"
+arch=(any)
+url="https://github.com/mclarkk/lifxlan"
+provides=('lifxlan')
+license=('MIT')
+depends=(
+ 'python'
+ 'python-requests'
+ 'python-setuptools'
+ 'python-bitstring'
+ 'python-netifaces'
+)
+conflicts=()
+source=("${_pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+src_git_dir="$srcdir/${_pkgname}"
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ python setup.py install --root="$pkgdir/"
+}