summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-02-14 17:36:35 +0100
committerBenjamin Chrétien2015-02-14 17:36:39 +0100
commit2f172d54440b7955720153ab1db9d15a061b19b1 (patch)
tree48052de43cb5ce5aee721ac3d43ed872448e4181
parent7d41f3cfc5fb89a31d30cd4b392b0735ec12433d (diff)
downloadaur-2f172d54440b7955720153ab1db9d15a061b19b1.tar.gz
indigo: fix sip error with PyQt 4.11.
Cf. ros-visualization/python_qt_binding#15
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--pyqt411.patch2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 029ffc128918..e5de4af3227d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ros-indigo-python-qt-binding
pkgdesc = ROS - This stack provides Python bindings for Qt.
pkgver = 0.2.14
- pkgrel = 2
+ pkgrel = 3
url = http://ros.org/wiki/python_qt_binding
arch = any
license = BSD, LGPL, GPL
@@ -16,7 +16,7 @@ pkgbase = ros-indigo-python-qt-binding
source = python_qt_binding::git+https://github.com/ros-gbp/python_qt_binding-release.git#tag=release/indigo/python_qt_binding/0.2.14-0
source = pyqt411.patch
md5sums = SKIP
- md5sums = 2c5c24536e83682411022e276dbd0d44
+ md5sums = c68f7f6f2e652130a0b599da69803758
pkgname = ros-indigo-python-qt-binding
diff --git a/PKGBUILD b/PKGBUILD
index 5b7784d15f9b..174c8833abd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-python-qt-binding'
pkgver='0.2.14'
_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD, LGPL, GPL')
ros_makedepends=(ros-indigo-catkin
@@ -26,7 +26,7 @@ _dir=python_qt_binding
source=("${_dir}"::"git+https://github.com/ros-gbp/python_qt_binding-release.git"#tag=${_tag}
"pyqt411.patch")
md5sums=('SKIP'
- '2c5c24536e83682411022e276dbd0d44')
+ 'c68f7f6f2e652130a0b599da69803758')
build() {
# Use ROS environment variables
diff --git a/pyqt411.patch b/pyqt411.patch
index 5d90b87e8850..c3f9af58f1c4 100644
--- a/pyqt411.patch
+++ b/pyqt411.patch
@@ -33,7 +33,7 @@ index dc2020d..7c0eec7 100644
+ "pyqt_version_str": QtCore.PYQT_VERSION_STR,
+ "pyqt_bin_dir": PyQt4.__path__[0],
+ "pyqt_mod_dir": PyQt4.__path__[0],
-+ "pyqt_sip_dir": "/usr/share/sip",
++ "pyqt_sip_dir": "/usr/share/sip/Py2-PyQt4",
+ "pyqt_modules": "QtCore QtGui", #... and many more
+ "pyqt_sip_flags": QtCore.PYQT_CONFIGURATION['sip_flags'],
+ "qt_version": QtCore.QT_VERSION,