summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2023-04-03 10:11:30 -0400
committerGuillaume Horel2023-04-03 10:11:30 -0400
commit2f19dcc30cb776031ac18d10ebe6a6925e9a2975 (patch)
tree41ddd8f569cb1639ea89050cff873f97f9daf0f5
parent0b82d471481c02f18b6d1a91278dfeb68818d7d3 (diff)
downloadaur-2f19dcc30cb776031ac18d10ebe6a6925e9a2975.tar.gz
bump to 0.3.23
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 729a5bcfadd7..6e88e045db68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openblas-lapack
pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
- pkgver = 0.3.22
- pkgrel = 2
+ pkgver = 0.3.23
+ pkgrel = 1
url = http://www.openblas.net/
arch = x86_64
license = BSD
@@ -19,7 +19,7 @@ pkgbase = openblas-lapack
conflicts = cblas
conflicts = lapacke
options = !emptydirs
- source = OpenBLAS-0.3.22.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v0.3.22/OpenBLAS-0.3.22.tar.gz
- sha256sums = 7fa9685926ba4f27cfe513adbf9af64d6b6b63f9dcabb37baefad6a65ff347a7
+ source = OpenBLAS-0.3.23.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v0.3.23/OpenBLAS-0.3.23.tar.gz
+ sha256sums = 5d9491d07168a5d00116cdc068a40022c3455bf9293c7cb86a65b1054d7e5114
pkgname = openblas-lapack
diff --git a/PKGBUILD b/PKGBUILD
index e2bd42a55178..d74fdc61c630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=openblas-lapack
_PkgName=OpenBLAS
_pkgname=openblas
-pkgver=0.3.22
+pkgver=0.3.23
# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
_lapackver=3.11.0
_blasver=3.11.0
-pkgrel=2
+pkgrel=1
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('x86_64')
url="http://www.openblas.net/"
@@ -21,7 +21,7 @@ provides=('openblas' "blas=${_blasver}" "lapack=${_lapackver}" "cblas=${_blasver
conflicts=('openblas' 'blas' 'lapack' 'cblas' 'lapacke')
options=(!emptydirs)
source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/OpenBLAS/releases/download/v${pkgver}/OpenBLAS-$pkgver.tar.gz)
-sha256sums=('7fa9685926ba4f27cfe513adbf9af64d6b6b63f9dcabb37baefad6a65ff347a7')
+sha256sums=('5d9491d07168a5d00116cdc068a40022c3455bf9293c7cb86a65b1054d7e5114')
# Add the following line to the _config variable if you want to set the number of make jobs
# MAKE_NB_JOBS=2 \
@@ -35,6 +35,12 @@ build(){
make ${_config} shared
}
+check() {
+ cd "${_PkgName}-${pkgver}"
+ unset MAKEFLAGS
+ make ${_config} tests
+}
+
package(){
cd "${_PkgName}-${pkgver}"