summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2015-08-03 19:41:33 +0100
committerWill Price2015-08-03 19:41:33 +0100
commit2f1ad83f642288ce784dd45504ffec1dc29d1a34 (patch)
tree3b0ff80e18bb35151b15ab54b9a09fc7323fd9c4
downloadaur-2f1ad83f642288ce784dd45504ffec1dc29d1a34.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0adc3630856b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nodejs-livedown
+ pkgdesc = Live Markdown previews for your favourite editor.
+ pkgver = 1.0.8
+ pkgrel = 1
+ url = https://github.com/shime/livedown
+ arch = any
+ depends = nodejs
+ noextract = livedown-1.0.8.tgz
+ source = http://registry.npmjs.org/livedown/-/livedown-1.0.8.tgz
+ sha1sums = 811c08413db1ecaf38d6ac1767f141fe1af37739
+
+pkgname = nodejs-livedown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ad4d7afc91c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Will Price <will.price94+aur@gmail.com>
+_npmname=livedown
+_npmver=1.0.8
+pkgname=nodejs-livedown # All lowercase
+pkgver=1.0.8
+pkgrel=1
+pkgdesc="Live Markdown previews for your favourite editor."
+arch=(any)
+url="https://github.com/shime/livedown"
+license=()
+depends=('nodejs' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(811c08413db1ecaf38d6ac1767f141fe1af37739)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et:
+
+# vim:set ts=2 sw=2 et: