summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2021-12-30 14:48:45 +0330
committerMohammadreza Abdollahzadeh2021-12-30 14:48:45 +0330
commit2f2f885dc2792e5fae30bdf58ca4cfd64e2ebbc2 (patch)
tree7120f2a29db1d6d2017067a4b3ca2449a8ad2c16
downloadaur-2f2f885dc2792e5fae30bdf58ca4cfd64e2ebbc2.tar.gz
initial import
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD78
-rw-r--r--seiscomp-sysusers.conf2
-rw-r--r--seiscomp-tmpfiles.conf2
-rw-r--r--seiscomp.install8
-rw-r--r--seiscomp.sh5
6 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60bf6ed764a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = seiscomp
+ pkgdesc = A seismological software for data acquisition, processing, distribution and interactive analysis.
+ pkgver = 4.8.2
+ pkgrel = 1
+ url = https://github.com/SeisComP
+ install = seiscomp.install
+ arch = x86_64
+ license = AGPL3
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ makedepends = libmariadbclient
+ makedepends = postgresql-libs
+ depends = boost-libs
+ depends = inetutils
+ depends = libxml2
+ depends = mariadb
+ depends = ncurses
+ depends = openssl
+ depends = python
+ depends = python-dateutil
+ depends = python-numpy
+ depends = python-twisted
+ depends = qt5-base
+ depends = qt5-svg
+ depends = sqlite
+ optdepends = postgresql: for using PostgreSQL database
+ source = seiscomp-4.8.2.tar.gz::https://github.com/SeisComP/seiscomp/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-seedlink-4.8.2.tar.gz::https://github.com/SeisComP/seedlink/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-common-4.8.2.tar.gz::https://github.com/SeisComP/common/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-main-4.8.2.tar.gz::https://github.com/SeisComP/main/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-extras-4.8.2.tar.gz::https://github.com/SeisComP/extras/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-contrib-gns-4.8.2.tar.gz::https://github.com/SeisComP/contrib-gns/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-contrib-ipgp-4.8.2.tar.gz::https://github.com/SeisComP/contrib-ipgp/archive/refs/tags/4.8.2.tar.gz
+ source = seiscomp-contrib-sed-4.8.2.tar.gz::https://github.com/SeisComP/contrib-sed/archive/refs/tags/4.8.2.tar.gz
+ source = https://www.seiscomp.de/downloader/seiscomp-4.8.2-doc.tar.gz
+ source = https://www.seiscomp.de/downloader/seiscomp-maps.tar.gz
+ source = seiscomp.sh
+ source = seiscomp-sysusers.conf
+ source = seiscomp-tmpfiles.conf
+ sha256sums = 8b09d09a07505869e6e90a0d58650ab899fa61225cf4e848c4c7d2701ef7a0f3
+ sha256sums = e37817760802224a965ec40fa023ea8998e5c340b783eb7bd45bbb1b4c71cde8
+ sha256sums = 7609dddd24da735c8bd29bf9001cc60aede154a160e07419a1c3878f2119dc9c
+ sha256sums = e4c270884169a4adce6d8002451443b12534653205825c6e27d7f41350d96a26
+ sha256sums = a3ebd77d29494eee74328f4d7166721441eb78746fa961c2976a8fc2868531d1
+ sha256sums = fd7bb441b0ebfdd0d09245c7c51b637cf9df8575242ac10cb03383090a94ce5e
+ sha256sums = cc18310617b436ee636a8cf476ef364c09dee9ac640ce8428737fd8dfa952703
+ sha256sums = 0d2351adb565ccd4ca356214cef2f985d3bdeed0a4b07537b21af66495b7c61f
+ sha256sums = 00875712e7ae512f8610e98f393afe0539cffa0adcde51a49d22bc199eacd829
+ sha256sums = e0488c4905260ab160b7ee2508ad5b70467665632b8f15428864cccb444e4cca
+ sha256sums = 0b752a57829d467ef66e4ddce314995a4ac7cfa1d99a548a967b15a427b87906
+ sha256sums = 4cdce628264921efa947ddccba19cf5fd2d6af21a9b23e6fbe8972558a27f182
+ sha256sums = 312911098291e60a40d4f3fd455b9a40b2d9b3489a589fb927fb6fc0b9ac2dd2
+
+pkgname = seiscomp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..455bafab9fe4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=seiscomp
+pkgver=4.8.2
+pkgrel=1
+pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis."
+arch=('x86_64')
+url="https://github.com/SeisComP"
+license=('AGPL3')
+depends=('boost-libs' 'inetutils' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python' 'python-dateutil' 'python-numpy' 'python-twisted' 'qt5-base' 'qt5-svg' 'sqlite')
+makedepends=('boost' 'cmake' 'git' 'libmariadbclient' 'postgresql-libs')
+optdepends=('postgresql: for using PostgreSQL database')
+install=${pkgname}.install
+source=("${pkgname}-${pkgver}.tar.gz::${url}/seiscomp/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-seedlink-${pkgver}.tar.gz::${url}/seedlink/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-common-${pkgver}.tar.gz::${url}/common/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-main-${pkgver}.tar.gz::${url}/main/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-extras-${pkgver}.tar.gz::${url}/extras/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-contrib-gns-${pkgver}.tar.gz::${url}/contrib-gns/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-contrib-ipgp-${pkgver}.tar.gz::${url}/contrib-ipgp/archive/refs/tags/${pkgver}.tar.gz"
+ "${pkgname}-contrib-sed-${pkgver}.tar.gz::${url}/contrib-sed/archive/refs/tags/${pkgver}.tar.gz"
+ "https://www.seiscomp.de/downloader/${pkgname}-${pkgver}-doc.tar.gz"
+ "https://www.seiscomp.de/downloader/${pkgname}-maps.tar.gz"
+ "${pkgname}.sh"
+ "${pkgname}-sysusers.conf"
+ "${pkgname}-tmpfiles.conf")
+sha256sums=('8b09d09a07505869e6e90a0d58650ab899fa61225cf4e848c4c7d2701ef7a0f3'
+ 'e37817760802224a965ec40fa023ea8998e5c340b783eb7bd45bbb1b4c71cde8'
+ '7609dddd24da735c8bd29bf9001cc60aede154a160e07419a1c3878f2119dc9c'
+ 'e4c270884169a4adce6d8002451443b12534653205825c6e27d7f41350d96a26'
+ 'a3ebd77d29494eee74328f4d7166721441eb78746fa961c2976a8fc2868531d1'
+ 'fd7bb441b0ebfdd0d09245c7c51b637cf9df8575242ac10cb03383090a94ce5e'
+ 'cc18310617b436ee636a8cf476ef364c09dee9ac640ce8428737fd8dfa952703'
+ '0d2351adb565ccd4ca356214cef2f985d3bdeed0a4b07537b21af66495b7c61f'
+ '00875712e7ae512f8610e98f393afe0539cffa0adcde51a49d22bc199eacd829'
+ 'e0488c4905260ab160b7ee2508ad5b70467665632b8f15428864cccb444e4cca'
+ '0b752a57829d467ef66e4ddce314995a4ac7cfa1d99a548a967b15a427b87906'
+ '4cdce628264921efa947ddccba19cf5fd2d6af21a9b23e6fbe8972558a27f182'
+ '312911098291e60a40d4f3fd455b9a40b2d9b3489a589fb927fb6fc0b9ac2dd2')
+
+scmodules=('seedlink' 'common' 'main' 'extras' 'contrib-gns' 'contrib-ipgp' 'contrib-sed')
+prepare() {
+ for scmod in "${scmodules[@]}"
+ do
+ cp -r "${scmod}-${pkgver}" "${pkgname}-${pkgver}/src/base/${scmod}"
+ done
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ mkdir build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/opt/seiscomp' \
+ -DCMAKE_CXX_FLAGS='-fPIC' \
+ -DCMAKE_SHARED_LINKER_FLAGS='-fPIC' \
+ -DCMAKE_EXE_LINKER_FLAGS='-fPIC -lpthread' \
+ -DPYTHON_EXECUTABLE='/usr/bin/python3' \
+ -DSC_GLOBAL_PYTHON_WRAPPER_PYTHON3='ON' \
+ -DSC_DOC_GENERATE='OFF'
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}/" install
+ install -D -m 644 "../src/system/apps/${pkgname}/share/shell-completion/${pkgname}.bash" \
+ "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ install -D -m 644 "../src/system/apps/${pkgname}/share/shell-completion/${pkgname}.fish" \
+ "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
+ cd ${srcdir}
+ cp -r "${pkgname}/share" "${pkgdir}/opt/${pkgname}/"
+ install -D -t "${pkgdir}/etc/profile.d/" -m 755 "${pkgname}.sh"
+ install -D -m 644 "${pkgname}-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -D -m 644 "${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ install -d "${pkgdir}/opt/${pkgname}/var"
+ chmod -R g+w "${pkgdir}/opt/${pkgname}"
+}
+# vim:set ts=4 sw=4 et:
diff --git a/seiscomp-sysusers.conf b/seiscomp-sysusers.conf
new file mode 100644
index 000000000000..aa2bd0ef43c0
--- /dev/null
+++ b/seiscomp-sysusers.conf
@@ -0,0 +1,2 @@
+#Type Name ID GECOS Home directory Shell
+u seiscomp - "SeisComp" - -
diff --git a/seiscomp-tmpfiles.conf b/seiscomp-tmpfiles.conf
new file mode 100644
index 000000000000..1b3c521a43fb
--- /dev/null
+++ b/seiscomp-tmpfiles.conf
@@ -0,0 +1,2 @@
+#Type Path Mode User Group Age Argument
+Z /opt/seiscomp - seiscomp seiscomp - -
diff --git a/seiscomp.install b/seiscomp.install
new file mode 100644
index 000000000000..e0de35a0bcd5
--- /dev/null
+++ b/seiscomp.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo " ->----------------------------------------------------------------<-"
+ echo " -> Before using seiscomp for first time you need to do following:"
+ echo " -> - Add your user to 'seiscomp' group:"
+ echo " -> sudo gpasswd -a $USERNAME seiscomp"
+ echo " -> - Restart your system or logout and login again."
+ echo " ->----------------------------------------------------------------<-"
+}
diff --git a/seiscomp.sh b/seiscomp.sh
new file mode 100644
index 000000000000..3c3387e041c3
--- /dev/null
+++ b/seiscomp.sh
@@ -0,0 +1,5 @@
+export SEISCOMP_ROOT="/opt/seiscomp"
+export PATH=/opt/seiscomp/bin:$PATH""
+export LD_LIBRARY_PATH="/opt/seiscomp/lib:$LD_LIBRARY_PATH"
+export PYTHONPATH=/opt/seiscomp/lib/python:$PYTHONPATH""
+export MANPATH="/opt/seiscomp/share/man:$MANPATH"