summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-26 11:45:06 -0500
committerLuis Martinez2022-08-26 11:45:06 -0500
commit2f375f1e430eba63d151c034ba805b0e50d0b8ec (patch)
treece2f75695820ba74efc83048ba9e98db2e6cf356
parent065ea786a9e0c21d7b3aa4ea052e989a63f78f78 (diff)
downloadaur-2f375f1e430eba63d151c034ba805b0e50d0b8ec.tar.gz
update to 2.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571b77c22962..1daac3fd7811 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = nerd-fonts-tinos
pkgdesc = Patched font Tinos from Nerd Fonts Library
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/ryanoasis/nerd-fonts
arch = any
- groups = nerd-fonts
- license = MIT
- depends = fontconfig
- provides = nerd-fonts-tinos
+ license = Apache
+ provides = ttf-nerd-fonts-tinos
conflicts = nerd-fonts-git
conflicts = nerd-fonts-complete
- source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.1.0/Tinos.zip
- source = https://github.com/ryanoasis/nerd-fonts/raw/v2.1.0/LICENSE
- sha1sums = SKIP
- sha1sums = SKIP
+ source = nerd-fonts-tinos-2.2.0.zip::https://github.com/ryanoasis/nerd-fonts/releases/download/v2.2.0/Tinos.zip
+ sha256sums = 97410f217c10788c9cf0e6348cd0282d86c38632061df9821880663db238313d
pkgname = nerd-fonts-tinos
-
diff --git a/PKGBUILD b/PKGBUILD
index bb536fb98815..db96c9866875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
-# Maintainer: pryme-svg <edoc.www@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: pryme-svg <edoc.www@gmail.com>
pkgname=nerd-fonts-tinos
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="Patched font Tinos from Nerd Fonts Library"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
-license=('MIT')
-depends=('fontconfig')
-provides=("${pkgname}")
+license=('Apache')
+provides=('ttf-nerd-fonts-tinos')
conflicts=('nerd-fonts-git' 'nerd-fonts-complete')
-groups=("nerd-fonts")
-source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v$pkgver/Tinos.zip"
- "https://github.com/ryanoasis/nerd-fonts/raw/v$pkgver/LICENSE")
-sha1sums=(SKIP
- SKIP)
+source=("$pkgname-$pkgver.zip::$url/releases/download/v$pkgver/Tinos.zip")
+sha256sums=('97410f217c10788c9cf0e6348cd0282d86c38632061df9821880663db238313d')
package() {
- find . -iname "*.otf" -not -iname "*Windows Compatible.otf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/OTF/{}" \;
- find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ find . -iname "*.ttf" -not -iname "*Windows Compatible.ttf" -execdir install -Dm644 {} "$pkgdir/usr/share/fonts/TTF/{}" \;
}
-