summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-01 01:38:01 +0000
committerDaniel Bermond2018-11-01 01:42:37 +0000
commit2f40b42113d33b944d224b53efe92b8b9eb0a36c (patch)
tree8d1a979ccce927172845422e63fc47f598e658d3
downloadaur-2f40b42113d33b944d224b53efe92b8b9eb0a36c.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD54
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bc61ea3916f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = intel-graphics-compiler-bin
+ pkgdesc = Intel Graphics Compiler for OpenCL
+ pkgver = 18.43.999
+ pkgrel = 1
+ url = https://github.com/intel/intel-graphics-compiler/
+ arch = x86_64
+ license = MIT
+ depends = gcc-libs
+ depends = zlib
+ depends = ncurses5-compat-libs
+ provides = intel-graphics-compiler
+ conflicts = intel-graphics-compiler
+ conflicts = compute-runtime
+ noextract = intel-igc-core_18.43.999_amd64.deb
+ noextract = intel-igc-opencl_18.43.999_amd64.deb
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/intel/compute-runtime/releases/download/18.43.11744/intel-igc-core_18.43.999_amd64.deb
+ source = https://github.com/intel/compute-runtime/releases/download/18.43.11744/intel-igc-opencl_18.43.999_amd64.deb
+ source = LICENSE
+ sha256sums = 633cbb8e05cafb7b768735035c85f2bb6e7d7bfb357792ebf0eef8636cacbf4a
+ sha256sums = 3aaab1ccb9e0e837b59727d7dea4963bee16f6e3353b17ac9ad5374fca636243
+ sha256sums = 0a17bb0830659515e66a960a6fd553d9ef939bc8097066e1c8f4954d562c252c
+
+pkgname = intel-graphics-compiler-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..52e428865a39
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2018, Intel Corporation
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76842bdcf551
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+
+# NOTE:
+# this binary package is currently provided by the intel-compute-runtime
+# repository. $pkgver is currently inherited from there.
+
+pkgname=intel-graphics-compiler-bin
+pkgver=18.43.999
+pkgrel=1
+pkgdesc='Intel Graphics Compiler for OpenCL'
+arch=('x86_64')
+url='https://github.com/intel/intel-graphics-compiler/'
+license=('MIT')
+depends=(
+ # official repositories:
+ 'gcc-libs' 'zlib'
+ # AUR:
+ 'ncurses5-compat-libs'
+)
+provides=('intel-graphics-compiler')
+conflicts=('intel-graphics-compiler' 'compute-runtime')
+options=('!strip' '!emptydirs')
+source=("https://github.com/intel/compute-runtime/releases/download/18.43.11744/intel-igc-core_${pkgver}_amd64.deb"
+ "https://github.com/intel/compute-runtime/releases/download/18.43.11744/intel-igc-opencl_${pkgver}_amd64.deb"
+ 'LICENSE')
+noextract=("intel-igc-core_${pkgver}_amd64.deb"
+ "intel-igc-opencl_${pkgver}_amd64.deb")
+sha256sums=('633cbb8e05cafb7b768735035c85f2bb6e7d7bfb357792ebf0eef8636cacbf4a'
+ '3aaab1ccb9e0e837b59727d7dea4963bee16f6e3353b17ac9ad5374fca636243'
+ '0a17bb0830659515e66a960a6fd553d9ef939bc8097066e1c8f4954d562c252c')
+
+prepare() {
+ mkdir -p igc-{core,opencl}-"$pkgver"
+
+ cd "igc-core-${pkgver}"
+ bsdtar -xf "${srcdir}/intel-igc-core_${pkgver}_amd64.deb" -s'|[^/]*/||'
+
+ cd "${srcdir}/igc-opencl-${pkgver}"
+ bsdtar -xf "${srcdir}/intel-igc-opencl_${pkgver}_amd64.deb" -s'|[^/]*/||'
+}
+
+package() {
+ cd "igc-core-${pkgver}"
+ tar -Jxf data.tar.xz -C "$pkgdir"
+ mv "$pkgdir"/usr/local/lib/* "${pkgdir}/usr/lib"
+
+ cd "${srcdir}/igc-opencl-${pkgver}"
+ tar -Jxf data.tar.xz -C "$pkgdir"
+
+ # fix wrong ownerships
+ chown root:root "$pkgdir"/usr/lib/libig{a64,c}.so
+
+ install -D -m644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}