summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Boman2020-07-12 16:58:40 +0200
committerMagnus Boman2020-07-12 16:58:40 +0200
commit2f49a72c9908068e9ed4e299478c5873ec4e19b6 (patch)
treecd8286082895e68693bc688e58bdad05f6704749
parentb253d9935f0145abc7ffc3d249df115e3a7dd0e7 (diff)
downloadaur-2f49a72c9908068e9ed4e299478c5873ec4e19b6.tar.gz
libopenaptx-git: clean up pkgbuild
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2d49506d207..b0b346a8821d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = libopenaptx-git
depends = glibc
provides = libopenaptx
conflicts = libopenaptx
- source = libopenaptx-git::git+https://github.com/pali/libopenaptx.git
+ source = git+https://github.com/pali/libopenaptx.git
sha512sums = SKIP
pkgname = libopenaptx-git
diff --git a/PKGBUILD b/PKGBUILD
index 9b2de8ee62fb..a5d382c66aec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,27 @@ pkgname=libopenaptx-git
pkgver=0.2.0.r1.g99b0921
pkgrel=1
pkgdesc='Open Source implementation of Audio Processing Technology codec (aptX)'
-arch=('x86_64')
-url="https://github.com/pali/libopenaptx"
-license=('LGPL2.1')
-depends=('glibc')
-makedepends=('git')
+arch=(x86_64)
+url='https://github.com/pali/libopenaptx'
+license=(LGPL2.1)
+depends=(glibc)
+makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("$pkgname::git+${url}.git")
-sha512sums=('SKIP')
+source=(git+"${url}".git)
+sha512sums=(SKIP)
pkgver() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
make
}
package() {
- cd "$pkgname"
+ cd "${pkgname%-git}"
make PREFIX=/usr DESTDIR="$pkgdir" install
}