summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-07-02 12:35:22 +0200
committeroli2015-07-02 12:35:22 +0200
commit2f5ed965764e30f2a6dd00ba709ec5be670735f4 (patch)
tree404e39246546f4535a9e67ebc814c1e1b4834387
downloadaur-2f5ed965764e30f2a6dd00ba709ec5be670735f4.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b500346675d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tt-rss-auth-ldap-git
+ pkgdesc = Tiny Tiny RSS plugin for LDAP authentication
+ pkgver = r24.b5a990c
+ pkgrel = 1
+ url = https://github.com/hydrian/TTRSS-Auth-LDAP
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = tt-rss
+ depends = php-ldap
+ depends = pear-net-ldap2
+ provides = tt-rss-auth-ldap
+ conflicts = tt-rss-auth-ldap
+ source = git+https://github.com/hydrian/TTRSS-Auth-LDAP.git
+ md5sums = SKIP
+
+pkgname = tt-rss-auth-ldap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88f60ea22633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=tt-rss-auth-ldap-git
+_gitname=TTRSS-Auth-LDAP
+pkgver=r24.b5a990c
+pkgrel=1
+pkgdesc="Tiny Tiny RSS plugin for LDAP authentication"
+arch=('any')
+url="https://github.com/hydrian/TTRSS-Auth-LDAP"
+license=('GPL2')
+depends=('tt-rss' 'php-ldap' 'pear-net-ldap2')
+makedepends=('git')
+provides=('tt-rss-auth-ldap')
+conflicts=('tt-rss-auth-ldap')
+source=('git+https://github.com/hydrian/TTRSS-Auth-LDAP.git')
+md5sums=('SKIP') #generate with 'makepkg -g'
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+ install -d -m755 "$pkgdir/usr/share/webapps/tt-rss/plugins/auth_ldap/"
+ install -D -m644 plugins/auth_ldap/init.php "$pkgdir/usr/share/webapps/tt-rss/plugins/auth_ldap/"
+}
+