summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-09-30 16:26:21 -0600
committerBrian Bidulock2015-06-10 16:18:20 -0600
commit2f6d4f6b211b2607dca8c8929a5502794ecdb93a (patch)
treebcd56dc30e6966de4ddeedf8f97a7dc0319f20ba
parent4c228f729efd01cb0ca8c388d4965ace5a37e316 (diff)
downloadaur-2f6d4f6b211b2607dca8c8929a5502794ecdb93a.tar.gz
version 2.0.0.r0.gd48d64d-1
-rw-r--r--.AURINFO2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--smcroute.conf.example11
4 files changed, 16 insertions, 7 deletions
diff --git a/.AURINFO b/.AURINFO
index a3fb5f81c66a..100612ddd5bd 100644
--- a/.AURINFO
+++ b/.AURINFO
@@ -1,6 +1,6 @@
pkgbase = smcroute-git
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 1.99.2.r91.gff0a2c0
+ pkgver = 2.0.0.r0.gd48d64d
pkgrel = 1
url = https://github.com/troglobit/smcroute
arch = i686
diff --git a/.SRCINFO b/.SRCINFO
index 6f8f054d5341..f6238cfd5612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = smcroute-git
pkgdesc = A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
- pkgver = 1.99.2.r91.gff0a2c0
+ pkgver = 2.0.0.r0.gd48d64d
pkgrel = 1
url = https://github.com/troglobit/smcroute
arch = i686
@@ -16,7 +16,7 @@ pkgbase = smcroute-git
source = smcroute.conf.example
source = smcroute.service
md5sums = SKIP
- md5sums = 59fdb2baf1184d0cb5c59b576b1b5e1c
+ md5sums = 98bdb5bbd222686761e318ee04825b7a
md5sums = 7b28500642045b2482f5ac873da0f86b
pkgname = smcroute-git
diff --git a/PKGBUILD b/PKGBUILD
index 6c737dc9a1dd..38f87cb611d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname="smcroute-git"
-pkgver=1.99.2.r91.gff0a2c0
+pkgver=2.0.0.r0.gd48d64d
pkgrel=1
pkgdesc="A command line tool to manipulate the multicast routes of a UNIX kernel. It supports both IPv4 and IPv6 multicast routing."
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("$pkgname::git+https://github.com/troglobit/smcroute.git"
'smcroute.service')
noextract=()
md5sums=('SKIP'
- '59fdb2baf1184d0cb5c59b576b1b5e1c'
+ '98bdb5bbd222686761e318ee04825b7a'
'7b28500642045b2482f5ac873da0f86b')
pkgver() {
@@ -36,6 +36,8 @@ package() {
install -Dm644 "${srcdir}/smcroute.conf.example" "${pkgdir}/etc/smcroute.conf"
install -Dm644 "${srcdir}/smcroute.service" "${pkgdir}/usr/lib/systemd/system/smcroute.service"
+ # nothing useful here
+ rm -fr "${pkgdir}/usr/share/doc"
}
# vim:set ts=2 sw=2 et:
diff --git a/smcroute.conf.example b/smcroute.conf.example
index b587fc706c39..d8b8d73cd54c 100644
--- a/smcroute.conf.example
+++ b/smcroute.conf.example
@@ -11,14 +11,21 @@
#
# Syntax:
# mgroup from IFNAME group MCGROUP
-# mroute from IFNAME source ADDRESS group MCGROUP to IFNAME [IFNAME ...]
+# mroute from IFNAME [source ADDRESS] group MCGROUP to IFNAME [IFNAME ...]
#
# The following example instructs the kernel to join the multicast
# group 225.1.2.3 on interface eth0. Followed by setting up an
# mroute of the same multicast stream, but from the explicit sender
# 192.168.1.42 on the eth0 network and forward to eth1 and eth2.
#
-
# mgroup from eth0 group 225.1.2.3
# mroute from eth0 group 225.1.2.3 source 192.168.1.42 to eth1 eth2
+# Here we allow routing of multicast to group 225.3.2.1 from ANY
+# source coming in from interface eth0 and forward to eth1 and eth2.
+# NOTE: Routing from ANY source is currently only available for IPv4
+# multicast.
+#
+# mgroup from eth0 group 225.3.2.1
+# mroute from eth0 group 225.3.2.1 to eth1 eth2
+