summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2019-12-23 14:49:19 -0500
committerChris Severance2019-12-23 14:49:19 -0500
commit2f8318a56fb31ae46a1e4520cc78c090a2f60607 (patch)
treee22d309ae7495975ddf850ca6cb43d9d7b973e84
parent4f638d56beba989fffc3b62862bcace987ee2b79 (diff)
downloadaur-2f8318a56fb31ae46a1e4520cc78c090a2f60607.tar.gz
autu: Update to 3.17.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1197252f2f8a..b9ac21e62f2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Fri Nov 29 23:30:03 UTC 2019
+# Mon Dec 23 19:49:19 UTC 2019
pkgbase = aws-eb-cli
pkgdesc = The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli
- pkgver = 3.16.0
+ pkgver = 3.17.0
pkgrel = 1
url = https://pypi.python.org/pypi/awsebcli
arch = any
license = Apache
makedepends = python
makedepends = python-distribute
- source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.16.0.tar.gz
- sha256sums = 03252f15f06f131e17644333cabe0221e446ff36fccad3d9434eeb7aef226c35
+ source = https://files.pythonhosted.org/packages/source/a/awsebcli/awsebcli-3.17.0.tar.gz
+ sha256sums = 0e6c3efde9676cc01087e9ffece851e5e271e21ce75182470bdbd2d78df0e191
pkgname = aws-eb-cli
depends = python
@@ -23,7 +23,7 @@ pkgname = aws-eb-cli
depends = python-future<0.17.0
depends = python-pathspec=0.5.9
depends = python-dateutil>=2.1
- depends = python-dateutil<3.0.0
+ depends = python-dateutil<2.8.1
depends = python-yaml>=3.10
depends = python-yaml<=3.13
depends = python-requests>=2.20.1
diff --git a/PKGBUILD b/PKGBUILD
index ea2e4482188a..0bc9dd7f776f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname="${_pyver}-${_pybase}"
_pyverother='' #python-'
fi
_pybasend="${_pybase//-/}"
-pkgver='3.16.0'
+pkgver='3.17.0'
pkgrel='1'
pkgdesc='The API and CLI tools that provide access to Amazon Elastic Beanstalk awsebcli'
arch=('any')
@@ -32,7 +32,7 @@ _verwatch=("https://pypi.org/simple/${_pybasend}/" "${_pybasend}-\([0-9\.]\+\)\.
# https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package
# https://bitbucket.org/pypa/pypi/issues/447/direct-links-of-packages-gone
source=("https://files.pythonhosted.org/packages/source/${_pybasend: 0:1}/${_pybasend}/${_pybasend}-${pkgver}.tar.gz")
-sha256sums=('03252f15f06f131e17644333cabe0221e446ff36fccad3d9434eeb7aef226c35')
+sha256sums=('0e6c3efde9676cc01087e9ffece851e5e271e21ce75182470bdbd2d78df0e191')
# Convert python requires to PKGBUILD depends
# $1: prefix python- or python2-
@@ -49,7 +49,7 @@ requires = [
'colorama>=0.3.9,<0.4.0', # use the same range that 'docker-compose' uses
'future>=0.16.0,<0.17.0',
'pathspec==0.5.9',
- 'python-dateutil>=2.1,<3.0.0', # use the same range that 'botocore' uses
+ 'python-dateutil>=2.1,<2.8.1', # use the same range that 'botocore' uses
'PyYAML>=3.10,<=3.13', # use the same range that 'aws-cli' uses. This is also compatible with 'docker-compose'
'requests>=2.20.1,<2.21',
'setuptools >= 20.0',