summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Stanchev2015-09-13 21:09:46 -0700
committerViktor Stanchev2015-09-13 21:11:00 -0700
commit2f8e9b591f88be1b07d9879135a098f80cb8466c (patch)
treeeada0678943d99c54394463f46b8fde21f09fd22
downloadaur-2f8e9b591f88be1b07d9879135a098f80cb8466c.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--urxvt-font-size.install8
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..911aad5e8c09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = urxvt-font-size-git
+ pkgdesc = On-the-fly URxvt font size adjustments
+ pkgver = 8
+ pkgrel = 1
+ url = https://github.com/majutsushi/urxvt-font-size
+ install = urxvt-font-size.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = rxvt-unicode
+ depends = xorg-xrdb
+ depends = xorg-xlsfonts
+ provides = urxvt-font-size
+ conflicts = urxvt-font-size
+ source = git://github.com/majutsushi/urxvt-font-size.git
+ md5sums = SKIP
+
+pkgname = urxvt-font-size-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7da0f5f86a1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Viktor Stanchev <me aatt viktorstanchev doot com>
+
+_pkgname=urxvt-font-size
+pkgname=${_pkgname}-git
+pkgver=8
+pkgrel=1
+pkgdesc='On-the-fly URxvt font size adjustments'
+arch=('any')
+url="https://github.com/majutsushi/${_pkgname}"
+license=('MIT')
+depends=('rxvt-unicode' 'xorg-xrdb' 'xorg-xlsfonts')
+makedepends=('git')
+provides=('urxvt-font-size')
+conflicts=('urxvt-font-size')
+install='urxvt-font-size.install'
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git://github.com/majutsushi/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-list --count HEAD
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D -m755 font-size "$pkgdir/usr/lib/urxvt/perl/font-size"
+ install -D -m644 README.markdown "$pkgdir/usr/share/doc/$pkgname/README.markdown"
+}
diff --git a/urxvt-font-size.install b/urxvt-font-size.install
new file mode 100644
index 000000000000..ea42921ccb35
--- /dev/null
+++ b/urxvt-font-size.install
@@ -0,0 +1,8 @@
+post_install () {
+ echo "==> For information on enabling the scripts,"
+ echo "==> see /usr/share/doc/urxvt-font-size-git/README.markdown"
+}
+
+post_upgrade () {
+ post_install $1
+}