aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Kellermann2018-10-05 10:55:01 -0400
committerAntony Kellermann2018-10-05 10:55:01 -0400
commit2fb2c7059782272fa7cbb90e833674b4a1b3de04 (patch)
tree3583541d9e7170981e3cc43475ddc1178770fc65
parent1cc721d5a4778f46b028a1634a957fdef6d77e52 (diff)
downloadaur-2fb2c7059782272fa7cbb90e833674b4a1b3de04.tar.gz
Changed CC to cc instead of gcc and moved libs/cflags to end of line. This fixes some issues using past versions of gcc
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 33644903a5d6..5c447d1de066 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-CC = gcc
+CC = cc
CFLAGS = -g -Wall --std=c99 -D_FORTIFY_SOURCE=2 -O2 \
-Wshadow -Wpointer-arith -pedantic -Wold-style-definition \
-Wno-missing-braces -Wextra -Wno-missing-field-initializers -Wformat=2 \
@@ -15,7 +15,7 @@ GLADE_FILES = window_main
DESTDIR = /usr
$(BIN): $(OBJECTS)
- $(CC) $(CFLAGS) $(LIBS) -o $(BIN) $(OBJECTS)
+ $(CC) -o $(BIN) $(OBJECTS) $(LIBS) $(CFLAGS)
-gzip $(BIN).1
install: $(BIN)
install -Dm755 $(BIN) $(DESTDIR)/bin/$(BIN)