summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-08 19:01:39 -0500
committerLuis Martinez2022-05-08 19:01:39 -0500
commit2fb47cd95b418514d495183aeeef08560d8d4bcc (patch)
tree1721d55ded5842ff81271e997fc6e03cdd0b1beb
parentb423b6bf8e5bf96979f528ee646a75eed07a35ef (diff)
downloadaur-2fb47cd95b418514d495183aeeef08560d8d4bcc.tar.gz
update to 1.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3048fc675e..9371ea2170ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-pyfirmata
- pkgdesc = Python interface for the Firmata
- pkgver = 1.0.3
+ pkgdesc = Python interface for the Firmata protocol
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/tino/pyFirmata
arch = any
license = MIT
- makedepends = python-distribute
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-pyserial
- options = !emptydirs
- source = https://github.com/tino/pyFirmata/archive/1.0.3.tar.gz
- md5sums = d391cf2975c6a48590d4727a3ce85eae
+ source = python-pyfirmata-1.1.0.tar.gz::https://files.pythonhosted.org/packages/source/p/pyFirmata/pyFirmata-1.1.0.tar.gz
+ sha256sums = cc180d1b30c85a2bbca62c15fef1b871db048cdcfa80959968356d97bd3ff08e
pkgname = python-pyfirmata
-
diff --git a/PKGBUILD b/PKGBUILD
index 47c69839948f..73380e391bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+
pkgname=python-pyfirmata
-pkgver=1.0.3
+_pkg="pyFirmata"
+pkgver=1.1.0
pkgrel=1
-pkgdesc="Python interface for the Firmata"
+pkgdesc="Python interface for the Firmata protocol"
arch=('any')
url="https://github.com/tino/pyFirmata"
license=('MIT')
depends=('python-pyserial')
-makedepends=('python-distribute')
-options=(!emptydirs)
-
-source=("https://github.com/tino/pyFirmata/archive/${pkgver}.tar.gz")
-md5sums=('d391cf2975c6a48590d4727a3ce85eae')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('cc180d1b30c85a2bbca62c15fef1b871db048cdcfa80959968356d97bd3ff08e')
build() {
- cd "$srcdir"/pyFirmata-$pkgver
-
- python setup.py build
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir"/pyFirmata-$pkgver
-
- python setup.py install --root="$pkgdir"/ --optimize=1
-
- install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/$_pkg-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}
-