summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaron de Leeuw2014-01-02 12:38:39 +0200
committerYaron de Leeuw2014-01-02 12:38:39 +0200
commit2fcb64bfeef68364ad96040bbdcb505b6c36cb21 (patch)
tree4482e667ceaaa6c3dce40352e1737c9ac61410d3
downloadaur-2fcb64bfeef68364ad96040bbdcb505b6c36cb21.tar.gz
added duplicity-backup-git
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore0
-rw-r--r--PKGBUILD32
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4a8c28fbb84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = duplicity-backup-git
+ pkgdesc = Bash wrapper script for automated backups with duplicity supporting S3
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/zertrin/duplicity-backup
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = duplicity
+ optdepends = gnupg: encryption support
+ optdepends = s3cmd: for storing on Amazon S3
+ optdepends = mailx: for mail notifications
+ backup = etc/duplicity-backup.conf
+ source = duplicity-backup-git::git+https://github.com/zertrin/duplicity-backup.git
+ md5sums = SKIP
+
+pkgname = duplicity-backup-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ece5dda45414
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Yaron de Leeuw <jdlmail@gmail.com>
+
+# Maintained at : https://github.com/jarondl/aur-pkgbuilds-jarondl
+
+pkgname=duplicity-backup-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Bash wrapper script for automated backups with duplicity supporting S3"
+arch=('any')
+url="https://github.com/zertrin/duplicity-backup"
+license=('GPL3')
+makedepends=('git')
+depends=('duplicity')
+optdepends=('gnupg: encryption support'
+ 's3cmd: for storing on Amazon S3'
+ 'mailx: for mail notifications')
+source=("$pkgname"::git+https://github.com/zertrin/duplicity-backup.git)
+md5sums=('SKIP')
+backup=('etc/duplicity-backup.conf')
+
+# find version according to
+# http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#Git
+pkgver() {
+ cd "$pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ install -D -m644 "$pkgname/duplicity-backup.conf.example" "$pkgdir/etc/duplicity-backup.conf"
+ install -D -m755 "$pkgname/duplicity-backup.sh" "$pkgdir/usr/bin/duplicity-backup"
+}