summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandrew (from workstation)2020-06-04 20:48:58 +0200
committerandrew (from workstation)2020-06-04 20:48:58 +0200
commit2fdcdb89188be1fcd8a5c2dc761ca942b1362cc7 (patch)
treed7f2dad19729429a6877b8685821a0474bb3f301
downloadaur-2fdcdb89188be1fcd8a5c2dc761ca942b1362cc7.tar.gz
first commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--tmulti.desktop12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d38d21a4f3ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tmulti-git
+ pkgdesc = Manage multiple Telegram Desktop account
+ pkgver = r16.ced5984
+ pkgrel = 1
+ url = https://github.com/andrew-ld/tmulti
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ makedepends = qt5-base
+ makedepends = imagemagick
+ depends = telegram-desktop
+ depends = qt5-base
+ provides = tmulti
+ source = tmulti::git+https://github.com/andrew-ld/tmulti
+ source = tmulti.desktop
+ sha1sums = SKIP
+ sha1sums = 42425bb1b5c33d5aab7ca8236a2766aac63fa1ab
+
+pkgname = tmulti-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07255ac28b33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: andrew-ld <andrew-ld@protonmail.com>
+
+pkgname=tmulti-git
+pkgver=r16.ced5984
+pkgrel=1
+pkgdesc="Manage multiple Telegram Desktop account"
+arch=(x86_64)
+url="https://github.com/andrew-ld/tmulti"
+license=("GPL3")
+depends=("telegram-desktop" "qt5-base")
+provides=("tmulti")
+makedepends=("git" "make" "gcc" "qt5-base" "imagemagick")
+source=("tmulti::git+https://github.com/andrew-ld/tmulti" "tmulti.desktop")
+sha1sums=("SKIP" "42425bb1b5c33d5aab7ca8236a2766aac63fa1ab")
+
+pkgver() {
+ cd "$srcdir/tmulti"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/tmulti"
+ qmake-qt5 .
+ make
+ convert "$srcdir/tmulti/res/icon.png" "$srcdir/tmulti.png"
+}
+
+package() {
+ cd "$srcdir/tmulti"
+ INSTALL_ROOT=$srcdir make install
+ install -Dm755 "$srcdir/opt/tmulti/bin/tmulti" -t "$pkgdir/usr/bin/"
+ install -Dm644 "$srcdir/tmulti.png" -t "$pkgdir/usr/share/pixmaps/"
+ install -Dm644 "$srcdir/tmulti.desktop" -t "$pkgdir/usr/share/applications/"
+}
diff --git a/tmulti.desktop b/tmulti.desktop
new file mode 100644
index 000000000000..5a38e578fcbc
--- /dev/null
+++ b/tmulti.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Name=TMulti
+Comment=Manage multiple Telegram Desktop account
+TryExec=telegram-desktop
+Exec=tmulti -- %u
+Icon=tmulti
+Terminal=false
+StartupWMClass=TMulti
+Type=Application
+Categories=Chat;Network;InstantMessaging;Qt;
+Keywords=tg;chat;im;messaging;messenger;sms;tdesktop;