summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhotonQuantum2019-07-17 18:44:53 +0800
committerPhotonQuantum2019-07-17 18:44:53 +0800
commit2fe4e3e6b4b6fb6b8d5bb1448587dcb88da7e9c0 (patch)
tree3c6b741de6ca529ec787461c434bd90c63416747
downloadaur-2fe4e3e6b4b6fb6b8d5bb1448587dcb88da7e9c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD33
-rw-r--r--kitty.patch18
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a1a696146f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = kitty-without-monolimit-git
+ pkgdesc = A modern, hackable, featureful, OpenGL based terminal emulator (monospace font limit removed).
+ pkgver = 0.14.2.r168.g9368f7f6
+ pkgrel = 1
+ url = https://github.com/kovidgoyal/kitty
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = libxinerama
+ makedepends = libxcursor
+ makedepends = libxrandr
+ makedepends = libxkbcommon
+ makedepends = libxkbcommon-x11
+ makedepends = glfw-x11
+ makedepends = wayland-protocols
+ makedepends = mesa
+ makedepends = python-sphinx
+ depends = python3
+ depends = freetype2
+ depends = fontconfig
+ depends = wayland
+ depends = libx11
+ depends = libgl
+ optdepends = imagemagick: viewing images with icat
+ provides = kitty
+ conflicts = kitty
+ source = git+https://github.com/kovidgoyal/kitty.git
+ source = kitty.patch
+ md5sums = SKIP
+ md5sums = ac7ea79c862f3d74f6b87804e433e6b7
+
+pkgname = kitty-without-monolimit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f948c20b53af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: LightQuantum<cy.n01@outlook.com>
+
+pkgname=kitty-without-monolimit-git
+pkgver=0.14.2.r168.g9368f7f6
+pkgrel=1
+pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator (monospace font limit removed)."
+arch=(i686 x86_64)
+url="https://github.com/kovidgoyal/kitty"
+license=(GPL3)
+depends=(python3 freetype2 fontconfig wayland libx11 libgl)
+makedepends=(git python-setuptools libxinerama libxcursor libxrandr libxkbcommon libxkbcommon-x11 glfw-x11 wayland-protocols mesa python-sphinx)
+optdepends=('imagemagick: viewing images with icat')
+provides=(kitty)
+conflicts=(kitty)
+source=("git+https://github.com/kovidgoyal/kitty.git" "kitty.patch")
+md5sums=('SKIP'
+ 'ac7ea79c862f3d74f6b87804e433e6b7')
+
+prepare() {
+ cd "$srcdir/${pkgname/-git/}"
+ patch --strip=1 --input="${srcdir}/kitty.patch"
+}
+
+pkgver() {
+ cd "$srcdir/${pkgname/-git/}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname/-git/}"
+
+ python3 setup.py linux-package --prefix "${pkgdir}"/usr
+}
diff --git a/kitty.patch b/kitty.patch
new file mode 100644
index 000000000000..1e411650f25c
--- /dev/null
+++ b/kitty.patch
@@ -0,0 +1,18 @@
+diff --unified --recursive kitty.orig/kitty/fonts/fontconfig.py kitty.new/kitty/fonts/fontconfig.py
+--- kitty.orig/kitty/fonts/fontconfig.py 2019-06-21 23:57:48.929339086 +0800
++++ kitty.new/kitty/fonts/fontconfig.py 2019-06-22 00:14:18.144595768 +0800
+@@ -55,12 +55,12 @@
+
+ def find_best_match(family, bold=False, italic=False, monospaced=True):
+ q = family_name_to_key(family)
+- font_map = all_fonts_map(monospaced)
++ font_map = all_fonts_map(False)
+
+ def score(candidate):
+ bold_score = abs((FC_WEIGHT_BOLD if bold else FC_WEIGHT_REGULAR) - candidate.get('weight', 0))
+ italic_score = abs((FC_SLANT_ITALIC if italic else FC_SLANT_ROMAN) - candidate.get('slant', 0))
+- monospace_match = 0 if candidate.get('spacing') == 'MONO' else 1
++ monospace_match = 1
+ return bold_score + italic_score, monospace_match
+
+ # First look for an exact match