summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2019-01-06 19:31:08 +0100
committergéballin2019-01-06 19:31:08 +0100
commit2ff61f233fb9449731d2126b232da75d952f3793 (patch)
tree3492e75746e79389fcbcda76a6258e0e6ac6093b
downloadaur-2ff61f233fb9449731d2126b232da75d952f3793.tar.gz
First commit of Slideshow 0.9 .
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b5380acaba3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = slideshow
+ pkgdesc = Draw a slideshow with the images in a directory or listed in a file and show it in a window or fullscreen.
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/Geballin/slideshow
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ makedepends = gcc
+ makedepends = make
+ depends = sdl
+ depends = sdl_image
+ source = https://github.com/Geballin/slideshow/archive/0.9.tar.gz
+ md5sums = c0f195d6f74c53aa8d2f11cd75307c8b
+
+pkgname = slideshow
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43fc33635699
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=slideshow
+pkgver=0.9
+pkgrel=1
+pkgdesc="Draw a slideshow with the images in a directory or listed in a file and show it in a window or fullscreen."
+url="https://github.com/Geballin/slideshow"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=(sdl sdl_image)
+optdepends=()
+makedepends=(gcc make)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/Geballin/slideshow/archive/0.9.tar.gz")
+
+md5sums=('c0f195d6f74c53aa8d2f11cd75307c8b')
+
+build() {
+ tar xzf ${pkgver}.tar.gz
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+ }
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ }