summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHåvard Pettersson2018-01-05 14:35:08 +0100
committerHåvard Pettersson2018-01-05 14:35:08 +0100
commit2ff8e65c37af96277b3e2a0ad9bc7e0021ab6903 (patch)
tree3a7668b91035acf3ca2c5b0659c084f7352c8241
downloadaur-2ff8e65c37af96277b3e2a0ad9bc7e0021ab6903.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01d4867139ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 5 13:35:01 UTC 2018
+pkgbase = python-iexfinance-git
+ pkgdesc = Python wrapper for the Investor's Exchange (IEX) Developer API
+ pkgver = r11.d60cb4b
+ pkgrel = 1
+ url = https://addisonlynch.github.io/iexfinance/
+ arch = any
+ license = apache
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python
+ source = python-iexfinance-git::git+https://github.com/addisonlynch/iexfinance.git
+ sha256sums = SKIP
+
+pkgname = python-iexfinance-git
+
+pkgname = python2-iexfinance-git
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..302c46daf017
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Håvard Pettersson <mail@haavard.me>
+
+pkgbase=python-iexfinance-git
+pkgname=(python-iexfinance-git python2-iexfinance-git)
+pkgver=r11.d60cb4b
+pkgrel=1
+pkgdesc="Python wrapper for the Investor's Exchange (IEX) Developer API"
+url='https://addisonlynch.github.io/iexfinance/'
+arch=(any)
+license=(apache)
+depends=(python)
+makedepends=(python-setuptools python2-setuptools)
+source=("${pkgname[0]}::git+https://github.com/addisonlynch/iexfinance.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${pkgname[0]}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cp -a ${pkgname[0]} ${pkgname[1]}
+}
+
+package_python-iexfinance-git() {
+ cd ${pkgname[0]}
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+package_python2-iexfinance-git() {
+ depends=(python2)
+
+ cd ${pkgname[1]}
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}