summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-05-13 04:40:07 +0800
committerlilac2023-05-13 04:40:07 +0800
commit30095cb91682a8853fb3abe23030c1598c6cb6ff (patch)
tree564232514373eb6528ba5646cfbee0e22655718d
parentd53c7b1553bd2e16ed94b5a99dfbad21746749e0 (diff)
downloadaur-30095cb91682a8853fb3abe23030c1598c6cb6ff.tar.gz
[lilac] updated to 99764-2
-rw-r--r--.SRCINFO8
-rw-r--r--009-properly-handle-i3wm.patch60
-rw-r--r--020-python-3-11.patch13
-rw-r--r--PKGBUILD8
4 files changed, 41 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b285289aaf63..52732e7dfb25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-svn
- pkgver = 98942
- pkgrel = 4
+ pkgver = 99764
+ pkgrel = 2
url = http://virtualbox.org
arch = x86_64
license = GPL
@@ -81,11 +81,11 @@ pkgbase = virtualbox-svn
sha256sums = 9ee947c9b5ec5b25f52d3e72340fc3a57ca6e65a604e15b669ac582a3fb0dc1b
sha256sums = 7675f87d31ad3137f057dc3ee3d4a2c5b2cfe8cd362adba130ddbf7a65069516
sha256sums = 053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491
- sha256sums = 92df121e1c8a1a967b4928a4d5c6f7ba8c91e43902ecd6d8f5fecc9df4184413
+ sha256sums = 010c89d6000633fffbdf9f9d93b1f3db7a9b92263e78c66251e6aa27a7919c04
sha256sums = 81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024
sha256sums = 00f68b86d32a1fada900c2da8dad2ab4215106cd58004f049bded99727cda2ff
sha256sums = 87dddfd9047480e4c2b73367facf5dd3702148418c2efcd606af17c07da90fe0
- sha256sums = 713fa594e8cb52946741839f8b73ffafedcd2e4ab03df169dd0c2c74ba9a18b4
+ sha256sums = aede7737a19dcff6908d216a4490f7b6a5640fb3a2d3e9200d4875133e8f1e4b
pkgname = virtualbox-svn
pkgdesc = Powerful x86 virtualization for enterprise as well as home use
diff --git a/009-properly-handle-i3wm.patch b/009-properly-handle-i3wm.patch
index 7d544fb79770..3ea6a5d3b3bb 100644
--- a/009-properly-handle-i3wm.patch
+++ b/009-properly-handle-i3wm.patch
@@ -1,34 +1,34 @@
-From 9284f5a37708ddf0108898a48eca5db0e5316a43 Mon Sep 17 00:00:00 2001
+From b9e64417e4c33e2c17e060aa482519c2c8c7d416 Mon Sep 17 00:00:00 2001
From: Christian Hesse <mail@eworm.de>
-Date: Mon, 17 Oct 2022 16:35:53 +0200
+Date: Tue, 17 Jan 2023 22:04:08 +0100
Subject: [PATCH] properly handle i3wm
---
- .../VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp | 4 ++--
- .../Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp | 3 +++
- .../Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h | 3 ++-
+ .../VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp | 3 ++-
+ .../Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.cpp | 3 +++
+ .../Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.h | 3 ++-
src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp | 4 ++++
- 4 files changed, 11 insertions(+), 3 deletions(-)
+ 4 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp b/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp
-index 9c5faa42..5439e2a7 100644
+index c27ff6f6..066a80e0 100644
--- a/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp
+++ b/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp
-@@ -385,7 +385,7 @@ QRect UIDesktopWidgetWatchdog::available
+@@ -385,7 +385,8 @@ QRect UIDesktopWidgetWatchdog::availableGeometry(QScreen *pScreen) const
/* Get cached available-geometry: */
const QRect availableGeometry = m_availableGeometryData.value(screenToIndex(pScreen));
/* Return cached available-geometry if it's valid or screen-geometry otherwise: */
- return availableGeometry.isValid() ? availableGeometry : screenGeometry(pScreen);
-+ return availableGeometry.isValid() && NativeWindowSubsystem::X11WindowManagerType() != X11WMType_i3 ? availableGeometry : screenGeometry(pScreen);
++ return availableGeometry.isValid() && NativeWindowSubsystem::X11WindowManagerType() != X11WMType_i3 ?
++ availableGeometry : screenGeometry(pScreen);
# endif /* !VBOX_GUI_WITH_CUSTOMIZATIONS1 */
#else /* !VBOX_WS_X11 */
/* Just return screen available-geometry: */
-
-diff --git a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp
-index 53927559..ea648da7 100644
---- a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp
-+++ b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp
-@@ -117,6 +117,9 @@ X11WMType NativeWindowSubsystem::X11WindowManagerType()
+diff --git a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.cpp b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.cpp
+index 2443af89..6cfcff74 100644
+--- a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.cpp
++++ b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.cpp
+@@ -141,6 +141,9 @@ X11WMType NativeWindowSubsystem::X11Wind
else
if (QString((const char*)pcData).contains("Xfwm4", Qt::CaseInsensitive))
wmType = X11WMType_Xfwm4;
@@ -38,11 +38,11 @@ index 53927559..ea648da7 100644
if (pcData)
XFree(pcData);
}
-diff --git a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h
-index bad78665..f2a0b462 100644
---- a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h
-+++ b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h
-@@ -49,6 +49,7 @@ enum X11WMType
+diff --git a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.h b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.h
+index 66504c71..f83b5c85 100644
+--- a/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.h
++++ b/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-nix.h
+@@ -51,6 +51,7 @@ enum X11WMType
X11WMType_Metacity,
X11WMType_Mutter,
X11WMType_Xfwm4,
@@ -50,20 +50,26 @@ index bad78665..f2a0b462 100644
};
/** X11: Screen-saver inhibit methods. */
-@@ -95,7 +96,7 @@
- /** X11: Determines and returns whether the compositing manager is running. */
- bool X11IsCompositingManagerRunning();
+@@ -102,11 +103,11 @@ namespace NativeWindowSubsystem
+ bool WaylandIsCompositingManagerRunning();
+
+ /** Wrapper for window manager type functions. */
+- X11WMType windowManagerType(bool fIsXServerAvailable);
++ SHARED_LIBRARY_STUFF X11WMType windowManagerType(bool fIsXServerAvailable);
/** X11: Determines and returns current Window Manager type. */
- X11WMType X11WindowManagerType();
+ SHARED_LIBRARY_STUFF X11WMType X11WindowManagerType();
+ /** Wayland: Determines and returns current Window Manager type. */
+- X11WMType WaylandWindowManagerType();
++ SHARED_LIBRARY_STUFF X11WMType WaylandWindowManagerType();
- #if 0 // unused for now?
- /** X11: Inits the screen saver save/restore mechanism. */
+ /** Wrapper for X11CheckExtension and WaylandCheckExtension functions. */
+ bool checkExtension(bool fIsXServerAvailable, const char *extensionName);
diff --git a/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp b/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp
-index 815db408..8cddb431 100644
+index 7b37d46b..b838ad07 100644
--- a/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp
+++ b/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp
-@@ -888,6 +888,10 @@ void UIMiniToolBar::prepare()
+@@ -1076,6 +1076,10 @@ void UIMiniToolBar::prepare()
/* Enable translucency through Qt API if supported: */
if (uiCommon().isCompositingManagerRunning())
setAttribute(Qt::WA_TranslucentBackground);
diff --git a/020-python-3-11.patch b/020-python-3-11.patch
index f040f1354d8a..1dd820b73ce8 100644
--- a/020-python-3-11.patch
+++ b/020-python-3-11.patch
@@ -1,16 +1,3 @@
-diff --git a/configure b/configure
-index 0872ec4c..037680e0 100755
---- a/configure
-+++ b/configure
-@@ -2132,7 +2132,7 @@ extern "C" int main(void)
- }
- EOF
- found=
-- SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m python3.10 python3.10m"
-+ SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m python3.10 python3.10m python3.11 python3.11m"
- for p in $PYTHONDIR; do
- for d in $SUPPYTHONLIBS; do
- for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
diff --git a/src/VBox/Installer/linux/routines.sh b/src/VBox/Installer/linux/routines.sh
index 08e06358..44eba726 100644
--- a/src/VBox/Installer/linux/routines.sh
diff --git a/PKGBUILD b/PKGBUILD
index 7dc78d05bec2..12f185ade4c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,9 @@ pkgname=('virtualbox-svn'
'virtualbox-guest-utils-svn'
'virtualbox-guest-utils-nox-svn'
'virtualbox-ext-vnc-svn')
-pkgver=98942
+pkgver=99764
_tarver=${pkgver}
-pkgrel=4
+pkgrel=2
arch=('x86_64')
url='http://virtualbox.org'
license=('GPL' 'custom:CDDL')
@@ -357,8 +357,8 @@ sha256sums=('SKIP'
'9ee947c9b5ec5b25f52d3e72340fc3a57ca6e65a604e15b669ac582a3fb0dc1b'
'7675f87d31ad3137f057dc3ee3d4a2c5b2cfe8cd362adba130ddbf7a65069516'
'053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491'
- '92df121e1c8a1a967b4928a4d5c6f7ba8c91e43902ecd6d8f5fecc9df4184413'
+ '010c89d6000633fffbdf9f9d93b1f3db7a9b92263e78c66251e6aa27a7919c04'
'81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024'
'00f68b86d32a1fada900c2da8dad2ab4215106cd58004f049bded99727cda2ff'
'87dddfd9047480e4c2b73367facf5dd3702148418c2efcd606af17c07da90fe0'
- '713fa594e8cb52946741839f8b73ffafedcd2e4ab03df169dd0c2c74ba9a18b4')
+ 'aede7737a19dcff6908d216a4490f7b6a5640fb3a2d3e9200d4875133e8f1e4b')