summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-31 19:48:37 +0800
committerzxp198210052024-01-31 19:48:37 +0800
commit30520b153abbb8efd183f1e7d514e37f084c2b51 (patch)
tree9cc74c8698918f4467023e9c26764b8b32426c5e
parent87ec6e7e8b3534a1589c34df31848e1b2dbbbb75 (diff)
downloadaur-30520b153abbb8efd183f1e7d514e37f084c2b51.tar.gz
update to 1.9.10
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
-rw-r--r--authpass.sh2
3 files changed, 15 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d2039fa43e..4aec521a025d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,18 @@
pkgbase = authpass-bin
pkgdesc = Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.
- pkgver = 1.9.9
- pkgrel = 4
+ pkgver = 1.9.10
+ pkgrel = 1
url = https://authpass.app/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = gtk3
depends = libsecret
depends = libkeybinder3
- depends = cairo
- depends = gdk-pixbuf2
- depends = libepoxy
- depends = at-spi2-core
- depends = pango
- depends = fontconfig
- depends = harfbuzz
- provides = authpass=1.9.9
+ provides = authpass=1.9.10
conflicts = authpass
- source = authpass-1.9.9.deb::https://github.com/authpass/authpass/releases/download/v1.9.9/authpass-linux-1.9.9_1977.deb
+ source = authpass-1.9.10.deb::https://github.com/authpass/authpass/releases/download/v1.9.10/authpass-linux-1.9.10_1994.deb
source = authpass.sh
- sha256sums = 91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102
- sha256sums = a48e111ef6e6a93e693545d524fdd46068aa4bc5d8508f2298e274cb1e342a1a
+ sha256sums = b4645eea43467dcafc5889b61d6e948ef3730d076de20c036a90298365e54fcb
+ sha256sums = 87aad073913a72e5fa1c7f4e0f6f695dafc5ba8ea675a62be03c532c701c243a
pkgname = authpass-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1960d9303d46..88cbcd9b4b1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,27 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname=authpass-bin
-pkgver=1.9.9
-pkgrel=4
+pkgver=1.9.10
+_subver=1994
+pkgrel=1
pkgdesc='Password Manager based on Flutter for all platforms. Keepass 2.x (kdbx 3.x) compatible.'
arch=('x86_64')
url="https://authpass.app/"
_ghurl="https://github.com/authpass/authpass"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
'gtk3'
'libsecret'
'libkeybinder3'
- 'cairo'
- 'gdk-pixbuf2'
- 'libepoxy'
- 'at-spi2-core'
- 'pango'
- 'fontconfig'
- 'harfbuzz'
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_1977.deb"
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-linux-${pkgver}_${_subver}.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('91816757def7919e67aef6a719453567306479a6864a86b269e5b5e78d09b102'
- 'a48e111ef6e6a93e693545d524fdd46068aa4bc5d8508f2298e274cb1e342a1a')
+sha256sums=('b4645eea43467dcafc5889b61d6e948ef3730d076de20c036a90298365e54fcb'
+ '87aad073913a72e5fa1c7f4e0f6f695dafc5ba8ea675a62be03c532c701c243a')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${pkgname%-bin}|g" \
diff --git a/authpass.sh b/authpass.sh
index dd5c3a0d256f..5f8466f8e866 100644
--- a/authpass.sh
+++ b/authpass.sh
@@ -5,4 +5,4 @@ _RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_RUNNAME}" "$@" | exit \ No newline at end of file
+exec "${_RUNNAME}" "$@" || exit $? \ No newline at end of file