summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorforumi07212016-06-21 15:14:26 +0900
committerforumi07212016-06-21 15:14:26 +0900
commit305a8df741c61493ebd72b07a3602269a8b447d0 (patch)
tree2a8ff887c5a08ed17bcf708b155832335b010d35
parent682491ff80866cace79a6e19dba6f210828298ed (diff)
downloadaur-305a8df741c61493ebd72b07a3602269a8b447d0.tar.gz
Update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
-rw-r--r--webvirtmgr-git.install6
-rw-r--r--webvirtmgr-novnc.service5
-rw-r--r--webvirtmgr.ini1
-rw-r--r--webvirtmgr.nginx.conf.sample23
6 files changed, 48 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 497c3634f2a2..07283ffb3a6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webvirtmgr-git
pkgdesc = Web front-end for KVM virtual machines
- pkgver = 4.8.7.r0.g05ff41c
- pkgrel = 2
+ pkgver = v4.8.9.r22.g79c8a8b
+ pkgrel = 1
url = https://www.webvirtmgr.net/
install = webvirtmgr-git.install
arch = i686
@@ -19,11 +19,16 @@ pkgbase = webvirtmgr-git
depends = python2
depends = supervisor
depends = websockify
+ options = !strip
+ options = !emptydirs
source = git+https://github.com/retspen/webvirtmgr.git
source = webvirtmgr.ini
source = webvirtmgr-novnc.service
- options = !strip
- options = !emptydirs
+ source = webvirtmgr.nginx.conf.sample
+ sha512sums = SKIP
+ sha512sums = 09469b807ab79177220f62316c2cbb7da72b4577f17c5a104d106a2392090753422740dc9dfb4f952e2d40e74ca7209ece911f7993dae0720659239d25c28d01
+ sha512sums = 9c7398213e13f7568bac5dbe996ee4ad0608d851612b2664d923cd82b109bcd4ae93ac7419e031c53f919c440f1fb5beaa7142e684007452f3950bfd0a812499
+ sha512sums = a81460d838ccefadbd3758fff492b6048c48dfd8d66be4494d91af5ebe8a0ab64627abac4ab83a3dfa541223120159cb79afee642fcf72f91f688729de6bff27
pkgname = webvirtmgr-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f37b96c29d1..0eac975f1671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='webvirtmgr-git'
pkgdesc='Web front-end for KVM virtual machines'
-pkgver=v4.8.8.r147.g64528fa
+pkgver=v4.8.9.r22.g79c8a8b
pkgrel=1
arch=('i686' 'x86_64')
url='https://www.webvirtmgr.net/'
@@ -14,11 +14,12 @@ options=('!strip' '!emptydirs')
install="${pkgname}.install"
source=('git+https://github.com/retspen/webvirtmgr.git'
'webvirtmgr.ini'
- 'webvirtmgr-novnc.service')
+ 'webvirtmgr-novnc.service'
+ 'webvirtmgr.nginx.conf.sample')
sha512sums=('SKIP'
- 'a8a64325750a1a6815c1ff9222373682f2300d0d636bb88675ae113b027a0e6d058e949344ae22357ff1258025ec0d32ca32a4383a37cadb88c9e5d180d2d147'
- '78ae3aef65e4c362a7d70ff3a44d1c3ccd489ed7b77311d0ecb4d795aa587dc75e43356f56e4afbb180e0558859b64cbe78ca45bb234920ff3302b01e59716db')
-PKGEXT='.pkg.tar.gz'
+ '09469b807ab79177220f62316c2cbb7da72b4577f17c5a104d106a2392090753422740dc9dfb4f952e2d40e74ca7209ece911f7993dae0720659239d25c28d01'
+ '9c7398213e13f7568bac5dbe996ee4ad0608d851612b2664d923cd82b109bcd4ae93ac7419e031c53f919c440f1fb5beaa7142e684007452f3950bfd0a812499'
+ 'a81460d838ccefadbd3758fff492b6048c48dfd8d66be4494d91af5ebe8a0ab64627abac4ab83a3dfa541223120159cb79afee642fcf72f91f688729de6bff27')
pkgver() {
cd 'webvirtmgr'
@@ -35,4 +36,7 @@ package() {
cd "${outputdir}"
pip2 install -r 'requirements.txt' -t "${outputdir}/lib"
+
+ install -dm0755 "${pkgdir}/etc/nginx/conf.d"
+ install -Dm0644 "${srcdir}/webvirtmgr.nginx.conf.sample" "${pkgdir}/etc/nginx/conf.d/webvirtmgr.nginx.conf.sample"
}
diff --git a/webvirtmgr-git.install b/webvirtmgr-git.install
index 7ec7ac627532..ffb6c07d527f 100644
--- a/webvirtmgr-git.install
+++ b/webvirtmgr-git.install
@@ -7,9 +7,9 @@ post_install() {
cat <<- EOF
To finalize the installation you need to run:
- # sudo python2 /usr/lib/webvirtmgr/manage.py syncdb
- # chown webvirtmgr:webvirtmgr /usr/lib/webvirtmgr/webvirtmgr/local/.secret_key_store /usr/lib/webvirtmgr/webvirtmgr.sqlite3 /usr/lib/webvirtmgr # temporary, see https://github.com/retspen/webvirtmgr/issues/391
- # sudo python2 /usr/lib/webvirtmgr/manage.py collectstatic
+ # sudo PYTHONPATH=/usr/lib/webvirtmgr/lib python2 /usr/lib/webvirtmgr/manage.py syncdb
+ # sudo chown webvirtmgr:webvirtmgr /usr/lib/webvirtmgr/webvirtmgr/local/.secret_key_store /usr/lib/webvirtmgr/webvirtmgr.sqlite3 /usr/lib/webvirtmgr # temporary, see https://github.com/retspen/webvirtmgr/issues/391
+ # sudo PYTHONPATH=/usr/lib/webvirtmgr/lib python2 /usr/lib/webvirtmgr/manage.py collectstatic
WebVirtMgr daemon is managed by Supervisord.
# systemctl enable supervisord
diff --git a/webvirtmgr-novnc.service b/webvirtmgr-novnc.service
index 64c9e90b6659..7b242cf7d673 100644
--- a/webvirtmgr-novnc.service
+++ b/webvirtmgr-novnc.service
@@ -2,13 +2,14 @@
Description=WebVirtMgr NoVNC proxy
[Service]
-Environment=WEBVIRTMGR_DAEMON=/usr/lib/webvirtmgr/console/webvirtmgr-novnc
+Environment=WEBVIRTMGR_DAEMON=/usr/lib/webvirtmgr/console/webvirtmgr-console
Environment=WEBVIRTMGR_LOCK_DIR=/var/lock/webvirtmgr
Environment=WEBVIRTMGR_USER=webvirtmgr
Environment=WEBVIRTMGR_GROUP=webvirtmgr
+Environment=PYTHONPATH=/usr/lib/webvirtmgr/lib
User=webvirtmgr
Group=webvirtmgr
-ExecStart=/usr/bin/python2 /usr/lib/webvirtmgr/console/webvirtmgr-novnc
+ExecStart=/usr/bin/python2 /usr/lib/webvirtmgr/console/webvirtmgr-console
Type=simple
[Install]
diff --git a/webvirtmgr.ini b/webvirtmgr.ini
index 413e074a1eb5..e1ea5cd8145a 100644
--- a/webvirtmgr.ini
+++ b/webvirtmgr.ini
@@ -6,3 +6,4 @@ autorestart=true
stdout_logfile=/var/log/supervisor/webvirtmgr.log
redirect_stderr=true
user=webvirtmgr
+environment=PYTHONPATH=/usr/lib/webvirtmgr/lib
diff --git a/webvirtmgr.nginx.conf.sample b/webvirtmgr.nginx.conf.sample
new file mode 100644
index 000000000000..1be2182a8485
--- /dev/null
+++ b/webvirtmgr.nginx.conf.sample
@@ -0,0 +1,23 @@
+server {
+ listen 8006 default_server;
+
+ server_name $hostname;
+ #access_log /var/log/nginx/webvirtmgr_access_log;
+
+ location /static/ {
+ root /usr/lib/webvirtmgr/webvirtmgr; # or /srv instead of /var
+ expires max;
+ }
+
+ location / {
+ proxy_pass http://127.0.0.1:8000;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-for $proxy_add_x_forwarded_for;
+ proxy_set_header Host $host:$server_port;
+ proxy_set_header X-Forwarded-Proto $scheme;
+ proxy_connect_timeout 600;
+ proxy_read_timeout 600;
+ proxy_send_timeout 600;
+ client_max_body_size 1024M; # Set higher depending on your needs
+ }
+}