summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-28 09:25:28 +0800
committerzxp198210052024-02-28 09:25:28 +0800
commit3063435502f93eaca8323f5f1738f1eacc05a374 (patch)
treec7dcdb503b8593799425a801df594b0bc161e48a
parentf6f977e0fe9c44a72b098ad8b0b6376097131b52 (diff)
downloadaur-3063435502f93eaca8323f5f1738f1eacc05a374.tar.gz
update to 6.0.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--whalebird.sh6
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15a786292742..0165bf4e66fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = whalebird-bin
pkgdesc = An Electron based Mastodon, Pleroma, and Misskey client
- pkgver = 6.0.1
+ pkgver = 6.0.2
pkgrel = 1
url = https://whalebird.social/
arch = x86_64
license = GPL-3.0-only
- depends = electron26
- provides = whalebird=6.0.1
+ depends = electron27
+ provides = whalebird=6.0.2
conflicts = whalebird
- source = whalebird-6.0.1.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.1/Whalebird-6.0.1-linux-amd64.deb
+ source = whalebird-6.0.2.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.2/Whalebird-6.0.2-linux-amd64.deb
source = whalebird.sh
- sha256sums = ec504833017fa60387e698f2f1e3ef83c190e358521dfd0b72e0a42f0dca2df5
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = f7072eef1d678b3184b1ea38856b8bcfc23cd67865d4f3ac0b0b3a584e0dc00c
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = whalebird-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6c560e9e606d..672ac96419a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
pkgname=whalebird-bin
_pkgname=Whalebird
-pkgver=6.0.1
-_electronversion=26
+pkgver=6.0.2
+_electronversion=27
pkgrel=1
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
arch=('x86_64')
@@ -21,14 +21,14 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('ec504833017fa60387e698f2f1e3ef83c190e358521dfd0b72e0a42f0dca2df5'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+sha256sums=('f7072eef1d678b3184b1ea38856b8bcfc23cd67865d4f3ac0b0b3a584e0dc00c'
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/whalebird.sh b/whalebird.sh
index 0d20cddc70ca..f9ced1432cfc 100644
--- a/whalebird.sh
+++ b/whalebird.sh
@@ -1,14 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file