summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Orth2016-06-20 03:46:53 +0200
committerJulian Orth2016-06-20 03:46:53 +0200
commit306848d478aaa5b4f3b332db6af2afa633b3ff23 (patch)
treeff4529357c7e14628930da938df9cf28055ec395
downloadaur-306848d478aaa5b4f3b332db6af2afa633b3ff23.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ee6cdad9b0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = spotblock-git
+ pkgdesc = A spotify ad blocker
+ pkgver = r1.2628a12
+ pkgrel = 1
+ url = https://github.com/mahkoh/spotblock
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = libsystemd
+ depends = libpulse
+ source = spotblock-git::git+https://github.com/mahkoh/spotblock
+ md5sums = SKIP
+
+pkgname = spotblock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd51626181a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Julian Orth <ju.orth@gmail.com>
+
+pkgname=spotblock-git
+pkgver=r1.2628a12
+pkgrel=1
+pkgdesc='A spotify ad blocker'
+arch=('i686' 'x86_64')
+url='https://github.com/mahkoh/spotblock'
+license=('GPL3')
+depends=('libsystemd' 'libpulse')
+source=("$pkgname::git+https://github.com/mahkoh/spotblock")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}