summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQirui Wang2019-03-17 06:36:17 -0400
committerQirui Wang2019-03-17 06:36:17 -0400
commit307a093f7869c171a10d0f6f453410e40cd5f667 (patch)
treea98ddafd998d290e5dfb739719416e9e9626ec9b
downloadaur-307a093f7869c171a10d0f6f453410e40cd5f667.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0365d237f21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rumur-git
+ pkgdesc = Yet another Murphi model checker
+ pkgver = 2019.03.11.r11.g9626824
+ pkgrel = 1
+ url = https://github.com/Smattr/rumur
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = cmake
+ makedepends = bison
+ makedepends = flex
+ makedepends = bison
+ makedepends = flex
+ depends = gmp
+ provides = rumur
+ conflicts = rumur
+ source = git+https://github.com/Smattr/rumur.git
+ sha256sums = SKIP
+
+pkgname = rumur-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ccb1321933f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Qirui Wang <wqr.prg@gmail.com>
+
+_name=rumur
+pkgname="$_name-git"
+pkgver=2019.03.11.r11.g9626824
+pkgrel=1
+pkgdesc="Yet another Murphi model checker"
+arch=('x86_64')
+url="https://github.com/Smattr/rumur"
+license=('custom')
+depends=('gmp')
+makedepends=('git' 'cmake' 'bison' 'flex' 'bison' 'flex')
+provides=("$_name")
+conflicts=("$_name")
+source=("git+https://github.com/Smattr/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ mkdir -p $_name/build
+}
+
+build() {
+ cd $_name/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+}
+
+check() {
+ cd $_name/build
+ ../tests/integration-tests.py --verbose
+}
+
+package() {
+ cd $_name/build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/licence"
+}