summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2021-04-24 18:15:27 -0300
committerTércio Martins2021-04-24 18:15:27 -0300
commit30855b7cc9ecfbf670e4f1560050a1675df97aac (patch)
treee0da6d57501f405b31e319ff3885915e49c38cd4
parent5e9ca93beffde8d7fec8f65ce38043e31002ffd4 (diff)
downloadaur-30855b7cc9ecfbf670e4f1560050a1675df97aac.tar.gz
PKGBUILD updated according to package "openfx-misc" version 2.4.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD59
2 files changed, 47 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69d57aa44ee7..06c781a2ea13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = openfx-misc-git
- pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
- pkgver = 2.3.11
+ pkgdesc = Miscellaneous OpenFX plugins
+ pkgver = Natron.2.4.0.r0.gf4c99c31
pkgrel = 1
- url = https://github.com/devernay/openfx-io
+ url = https://github.com/NatronGitHub/openfx-misc
arch = x86_64
- license = GPL2
- makedepends = git
- makedepends = expat
- makedepends = boost
- depends = seexpr
- depends = openimageio
- depends = ffmpeg
- optdepends = openfx-gmic-bin
- optdepends = natron-plugins
- source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc.git#commit=5eb5904c1d691c68e4eb09fe2f241e388ecc03c1
+ license = GPL
+ makedepends = openmp
+ depends = libgl
+ optdepends = natron-plugins-git: More presets for the Shadertoy plugin
+ conflicts = openfx-misc
+ source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc
+ source = openfx::git+https://github.com/NatronGitHub/openfx
+ source = openfx-supportext::git+https://github.com/NatronGitHub/openfx-supportext
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = openfx-misc-git
diff --git a/PKGBUILD b/PKGBUILD
index cce0d03591af..de2034710e5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,47 @@
-# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
-# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+# Maintainer: Tércio Martins <echo dGVyY2lvd2VuZGVsQGdtYWlsLmNvbQo= | base64 -d>
+# Contributor: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-misc-git
-name=openfx-misc
-pkgver=2.3.11
+pkgver=Natron.2.4.0.r0.gf4c99c31
pkgrel=1
-arch=("x86_64")
-pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
-url="https://github.com/devernay/openfx-io"
-license=("GPL2")
-depends=("seexpr" "openimageio" "ffmpeg")
-#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
-makedepends=("git" "expat" "boost")
-optdepends=("openfx-gmic-bin" "natron-plugins")
-com=5eb5904c1d691c68e4eb09fe2f241e388ecc03c1
-source=("openfx-misc::git+https://github.com/NatronGitHub/openfx-misc.git#commit=$com"
-)
-sha512sums=('SKIP'
-)
+arch=('x86_64')
+pkgdesc="Miscellaneous OpenFX plugins"
+url="https://github.com/NatronGitHub/openfx-misc"
+license=('GPL')
+depends=('libgl')
+makedepends=('openmp')
+optdepends=('natron-plugins-git: More presets for the Shadertoy plugin')
+
+_pkgname=${pkgname%-git}
+_url=${url%/${_pkgname}}
-_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+${url}"
+ "openfx::git+${_url}/openfx"
+ "openfx-supportext::git+${_url}/openfx-supportext")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "$srcdir/$name"
- git submodule update --init --recursive
+ cd ${_pkgname}
+ git submodule init
+ git config submodule.openfx.url ${srcdir}/openfx
+ git config submodule.SupportExt.url ${srcdir}/openfx-supportext
+ git submodule update
}
build() {
- cd "$srcdir/$name"
- make CONFIG=release BITS=$_bits
+ cd "${srcdir}/${_pkgname}"
+ make CONFIG=release \
+ OPENMP=1
}
package() {
- cd "$srcdir/$name"
- mkdir -p "$pkgdir/usr/OFX/Plugins"
- make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/OFX/Plugins"
+ make install PLUGINPATH="${pkgdir}/usr/OFX/Plugins" \
+ CONFIG=release
}