summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:27:55 -0400
committerKyle Keen2015-06-13 00:27:55 -0400
commit30900f858cdae029dd759aaf77ffe29caefa6e17 (patch)
tree28bdcebfb4332c0e9c799bea8b0265ff5f53d4e4
downloadaur-30900f858cdae029dd759aaf77ffe29caefa6e17.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--magic.changelog48
4 files changed, 121 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..04b937ce54a9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = magic
+ pkgdesc = A VLSI layout system
+ pkgver = 8.0.206
+ pkgrel = 1
+ url = http://opencircuitdesign.com/magic/
+ changelog = magic.changelog
+ arch = i686
+ arch = x86_64
+ license = custom:copyright
+ makedepends = tcsh
+ depends = tcl
+ depends = tk
+ depends = libx11
+ optdepends = mesa: for better graphics
+ optdepends = blt: to create a tree diagram of the cell hierarchy in a design
+ source = http://opencircuitdesign.com/magic/archive/magic-8.0.206.tgz
+
+pkgname = magic
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c570f63bf34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = magic
+ pkgdesc = A VLSI layout system
+ pkgver = 8.0.206
+ pkgrel = 1
+ url = http://opencircuitdesign.com/magic/
+ changelog = magic.changelog
+ arch = i686
+ arch = x86_64
+ license = custom:copyright
+ makedepends = tcsh
+ depends = tcl
+ depends = tk
+ depends = libx11
+ optdepends = mesa: for better graphics
+ optdepends = blt: to create a tree diagram of the cell hierarchy in a design
+ source = http://opencircuitdesign.com/magic/archive/magic-8.0.206.tgz
+ md5sums = c153fbde29fcf589a58dc23889ebf064
+
+pkgname = magic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfa4d08c81db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jared Casper <jaredcasper@gmail.com>
+pkgname=magic
+pkgver=8.0.206
+pkgrel=1
+pkgdesc="A VLSI layout system"
+url="http://opencircuitdesign.com/magic/"
+arch=('i686' 'x86_64')
+license=('custom:copyright')
+depends=('tcl' 'tk' 'libx11')
+makedepends=('tcsh')
+optdepends=('mesa: for better graphics'
+ 'blt: to create a tree diagram of the cell hierarchy in a design')
+changelog=$pkgname.changelog
+source=(http://opencircuitdesign.com/magic/archive/$pkgname-$pkgver.tgz)
+md5sums=('c153fbde29fcf589a58dc23889ebf064')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make -j1 DESTDIR="$pkgdir" MANDIR=/usr/share/man install
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ if [ -x /usr/bin/ps2ascii ]; then
+ /usr/bin/ps2ascii "$pkgdir/usr/lib/magic/doc/copyright.ps" > "$pkgdir/usr/share/licenses/$pkgname/copyright"
+ else
+ install -m644 "$pkgdir/usr/lib/magic/doc/copyright.ps" "$pkgdir/usr/share/licenses/magic"
+ fi
+ mv "$pkgdir/usr/share/man/man1/extcheck.1" "$pkgdir/usr/share/man/man1/extcheck-magic.1"
+}
+
diff --git a/magic.changelog b/magic.changelog
new file mode 100644
index 000000000000..074499a974bc
--- /dev/null
+++ b/magic.changelog
@@ -0,0 +1,48 @@
+2015-05-03 Kyle Keen <keenerd@gmail.com>
+ * 8.0.206
+ - Version bump
+
+2013-10-21 Kyle Keen <keenerd@gmail.com>
+ * 7.5.233
+ - Version bump
+ - license var
+ - arch var
+
+2013-01-29 Kyle Keen <keenerd@gmail.com>
+ * 7.5.230
+ - Version bump
+ - Fix jdk7-openjdk conflict
+ - Quoting
+
+2010-09-21 Jared Casper <jaredcasper@gmail.com>
+ * 7.5.207-1
+ - Version bump
+ - use changelog variable
+ - split build() and package()
+ - remove || return 1
+ - mkdir/cp -> install
+ - correct man directory
+
+2010-04-07 Jared Casper <jaredcasper@gmail.com>
+ * 7.5.190-1
+ - Version bump
+ - builddepends -> makedepends in PKGBUILD
+
+2010-01-08 Jared Casper <jaredcasper@gmail.com>
+ * 7.5.188-1
+ - Version bump (finally)
+
+2008-09-28 Jared Casper <jaredcasper@gmail.com>
+ * 7.5.151-1
+ - Version Bump
+ - Removed sed from PKGBUILD that was now unnecessary and causing problems
+
+2008-06-08 Jared Casper <jaredcasper@gmail.com>
+
+ * 7.5.143-1
+ - Version bump
+
+2008-05-15 Jared Casper <jaredcasper@gmail.com>
+
+ * 7.5.137-1
+ - Initial package