summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2017-12-27 00:08:33 -0500
committerEli Schwartz2017-12-27 00:08:33 -0500
commit30a49682b0acaad3f2264393f27ee3c762175a27 (patch)
tree29aea5b29a89ac400f7691b61d7533cad10a00cf
parent17e6bd1d765c95f87ac0b869e12a041536339c3c (diff)
downloadaur-30a49682b0acaad3f2264393f27ee3c762175a27.tar.gz
upgpkg: xbps 0.51-2
Adopt package, fix horrible pkgdesc, and fix build errors.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eadfba4b051f..85447c2bcbf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
-# Generated by mksrcinfo v8
-# Sat Dec 19 20:22:35 UTC 2015
pkgbase = xbps
- pkgdesc = Sick of systemd? Let's try out Void Linux!
+ pkgdesc = The X Binary Package System from Void Linux. Don't use it instead of Arch's 'pacman'.
pkgver = 0.51
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/voidlinux/xbps
arch = i686
arch = x86_64
license = custom:2-clause-BSD
- makedepends = zlib
- makedepends = openssl
depends = ca-certificates
depends = libarchive
- source = https://github.com/voidlinux/xbps/archive/0.51.tar.gz
+ depends = openssl-1.0
+ source = xbps-0.51.tar.gz::https://github.com/voidlinux/xbps/archive/0.51.tar.gz
+ source = fix-lflags.patch::https://github.com/voidlinux/xbps/commit/e8c1ae96ae487e4aa84d22a5a045df0e2a7113f5.patch
+ source = fix-openssl.patch::https://github.com/voidlinux/xbps/commit/861617a708622d1411d88a45e1c5c644d497c086.patch
md5sums = 8acd65768e3be3827841f3a5848a19d7
+ md5sums = 38438c0ea4369b77d333372e5212a382
+ md5sums = 836cfb2a0a762e4943a6c0a565beaadd
pkgname = xbps
diff --git a/PKGBUILD b/PKGBUILD
index 5a6ad72d5e7e..ac2544ef84da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,43 @@
-# Maintainer: robotanarchy
-# See also: https://github.com/voidlinux/void-packages/blob/master/srcpkgs/xbps/template
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=xbps
pkgver=0.51
-pkgrel=1
-pkgdesc="Sick of systemd? Let's try out Void Linux!"
+pkgrel=2
+pkgdesc="The X Binary Package System from Void Linux. Don't use it instead of Arch's 'pacman'."
arch=('i686' 'x86_64')
url="https://github.com/voidlinux/xbps"
-license=("custom:2-clause-BSD")
-depends=("ca-certificates" "libarchive")
-makedepends=("zlib" "openssl")
-source=("https://github.com/voidlinux/xbps/archive/$pkgver.tar.gz")
-md5sums=('8acd65768e3be3827841f3a5848a19d7')
+license=('custom:2-clause-BSD')
+depends=('ca-certificates' 'libarchive' 'openssl-1.0')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/voidlinux/xbps/archive/$pkgver.tar.gz"
+ "fix-lflags.patch::https://github.com/voidlinux/xbps/commit/e8c1ae96ae487e4aa84d22a5a045df0e2a7113f5.patch"
+ "fix-openssl.patch::https://github.com/voidlinux/xbps/commit/861617a708622d1411d88a45e1c5c644d497c086.patch")
+md5sums=('8acd65768e3be3827841f3a5848a19d7'
+ '38438c0ea4369b77d333372e5212a382'
+ '836cfb2a0a762e4943a6c0a565beaadd')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < ../fix-lflags.patch
+ patch -p1 < ../fix-openssl.patch
+}
build() {
- cd "$pkgname-$pkgver"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --bindir=/usr/bin \
- --localstatedir=/var/lib/xbps
- make
+ cd "$pkgname-$pkgver"
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --dbdir=/var/lib/xbps
+
+ sed -i '/-Werror/d' config.mk
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
- install -Dm644 COPYING.3RDPARTY "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm644 COPYING.3RDPARTY "$pkgdir/usr/share/licenses/$pkgname/COPYING.3RDPARTY"
}