summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Moore2024-02-09 13:43:58 -0500
committerTom Moore2024-02-09 13:43:58 -0500
commit30ad5c73abb6ce63488dc7fb7291dcdd4708bbd8 (patch)
treefba93c7dcb3608d2f88f1b3ebb42f10ad6b37096
parenta0e64b8a0a3e58a8063a311328c06c117c4ebb68 (diff)
downloadaur-30ad5c73abb6ce63488dc7fb7291dcdd4708bbd8.tar.gz
Version update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e58b277e8ce..4d74c9b276ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = chef-workstation
- pkgdesc = Chef Workstation gives you everything you need to get started with Chef. Start scanning and configuring your environments today with InSpec and chef-run.
- pkgver = 23.5.1040
+ pkgdesc = Chef's developer toolkit that includes Infra, InSpec, Habitat, and tools like knife.
+ pkgver = 23.12.1055
pkgrel = 1
- url = https://downloads.chef.io/chef-workstation/
+ url = https://www.chef.io/downloads/tools/workstation
arch = x86_64
license = custom:Chef EULA
conflicts = chef-dk
conflicts = chef
conflicts = chef-solo
conflicts = cinc
- source = https://packages.chef.io/files/stable/chef-workstation/23.5.1040/debian/11/chef-workstation_23.5.1040-1_amd64.deb
- sha256sums = fbace5a45c3bf857b72791a893b9dd3ddd80507165aeb80219329e6523e74305
+ replaces = chef-dk
+ source = https://packages.chef.io/repos/apt/stable/ubuntu/20.04/chef-workstation_23.12.1055-1_amd64.deb
+ sha256sums = 383b269ef486018b9d36849ba6267054085c296a097adf1bd00bd7446dee7452
pkgname = chef-workstation
depends = libxcrypt-compat
diff --git a/PKGBUILD b/PKGBUILD
index fa3de5c56e1c..d5da754984e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Paweł Otlewski <pawel@idkcloud.com>
+# Maintainer: Tom Moore <middleagedman@users.noreply.github.com>
+# Contributor: Paweł Otlewski <pawel@idkcloud.com>
# shellcheck disable=SC2148 # Ignore lack of shebang
# shellcheck disable=SC2034 # Ignore "unused" PKGBUILD variables
# shellcheck disable=SC2154 # Ignore "unassigned" references to $srcdir and $pkgdir
pkgname=chef-workstation
-pkgver=23.5.1040
+pkgver=23.12.1055
pkgrel=1
pkgdesc="Chef's developer toolkit that includes Infra, InSpec, Habitat, and tools like knife."
arch=('x86_64')
@@ -14,8 +15,8 @@ license=('custom:Chef EULA')
depends=()
conflicts=(chef-dk chef chef-solo cinc)
replaces=('chef-dk')
-source=('https://packages.chef.io/files/stable/chef-workstation/23.5.1040/debian/11/chef-workstation_23.5.1040-1_amd64.deb')
-sha256sums=('fbace5a45c3bf857b72791a893b9dd3ddd80507165aeb80219329e6523e74305')
+source=("https://packages.chef.io/repos/apt/stable/ubuntu/20.04/chef-workstation_$pkgver-1_amd64.deb")
+sha256sums=('383b269ef486018b9d36849ba6267054085c296a097adf1bd00bd7446dee7452')
package() {
depends=('libxcrypt-compat')