summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragafron2019-06-17 16:00:14 +0300
committeragafron2019-06-17 16:00:14 +0300
commit30b5d87a2bdce360240e8233f85d1b1a7158b3a1 (patch)
treef00a3907eace4e6ca3580ccd682a583bd2e7618a
downloadaur-30b5d87a2bdce360240e8233f85d1b1a7158b3a1.tar.gz
v5.2-test
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f714ae7807ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zvvonlinetv-test
+ pkgdesc = TV | IPTV | youtube player(testing)
+ pkgver = 5.2
+ pkgrel = 1
+ url = https://zvvubuntu.blogspot.com
+ arch = i386
+ arch = x86_64
+ license = custom
+ depends = pyqt5-common
+ depends = python-pyqt5
+ depends = mpv
+ depends = qt5-multimedia
+ depends = ffmpeg
+ depends = youtube-dl
+ conflicts = zvvonlinetv
+ source = zvvonlinetv-test_5.2.deb::https://docs.google.com/uc?id=17lWM4Kmg-xS4I31ygl16tKo3Y1TdcSwg
+ md5sums = 5a543ce9294aa6d2c3b77450b573a4e4
+
+pkgname = zvvonlinetv-test
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f34eb817b06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ZVVUbuntu
+_pkgname=zvvonlinetv
+pkgtest=test
+pkgname=${_pkgname}-$pkgtest
+pkgver=5.2
+pkgrel=1
+pkgdesc="TV | IPTV | youtube player(testing)"
+arch=('i386' 'x86_64')
+url="https://zvvubuntu.blogspot.com"
+license=('custom')
+depends=('pyqt5-common' 'python-pyqt5' 'mpv' 'qt5-multimedia' 'ffmpeg' 'youtube-dl')
+conflicts=('zvvonlinetv')
+source=("${pkgname}_${pkgver}.deb::https://docs.google.com/uc?id=17lWM4Kmg-xS4I31ygl16tKo3Y1TdcSwg")
+md5sums=('5a543ce9294aa6d2c3b77450b573a4e4')
+
+package() {
+ cd "${srcdir}"
+ bsdtar -xf data.tar.xz -C "$pkgdir"
+ chmod -R 755 "${pkgdir}"/usr
+ chmod -R 775 "${pkgdir}"/usr/share/${_pkgname}
+ chmod -R 775 "${pkgdir}"/usr/share/${_pkgname}/modules/
+
+ ######################################################
+ #install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+ #install -Dm755 $_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+}