summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxlwz2021-08-26 16:30:36 +0800
committerxlwz2021-08-26 16:30:36 +0800
commit30b79e04b7b7afc48f5e683630049fb908f6ec7c (patch)
tree9354a1702ae71352d0ba2ca2df2a17061ffd28a8
downloadaur-30b79e04b7b7afc48f5e683630049fb908f6ec7c.tar.gz
2.1.2.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a633ac4d902
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = keepass-plugin-onedrivesync
+ pkgdesc = KeePass plugin to allows syncing of KeePass databases stored on OneDrive Personal, OneDrive for Business or SharePoint.
+ pkgver = 2.1.2.1
+ pkgrel = 1
+ url = https://github.com/KoenZomers/KeePassOneDriveSync
+ arch = any
+ license = EPL
+ depends = keepass
+ provides = keepassonedrivesync
+ conflicts = keepassonedrivesync
+ source = https://github.com/KoenZomers/KeePassOneDriveSync/releases/download/2.1.2.1/KeeOneDriveSync.plgx
+ sha256sums = 9f0585b43ebf69aaa24bb51a1c2f2a9cd6ad663ba852af86c99771eb537dd1a0
+
+pkgname = keepass-plugin-onedrivesync
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d6bd325ec9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: xlwz <xlwzforever@outlook.com>
+
+pkgname=keepass-plugin-onedrivesync
+pkgver=2.1.2.1
+pkgrel=1
+pkgdesc="KeePass plugin to allows syncing of KeePass databases stored on OneDrive Personal, OneDrive for Business or SharePoint."
+license=('EPL')
+depends=('keepass')
+provides=('keepassonedrivesync')
+conflicts=('keepassonedrivesync')
+arch=('any')
+url="https://github.com/KoenZomers/KeePassOneDriveSync"
+source=(https://github.com/KoenZomers/KeePassOneDriveSync/releases/download/$pkgver/KeeOneDriveSync.plgx)
+sha256sums=('9f0585b43ebf69aaa24bb51a1c2f2a9cd6ad663ba852af86c99771eb537dd1a0')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/keepass/plugins
+ install -m644 KeeOneDriveSync.plgx "${pkgdir}"/usr/share/keepass/plugins/
+}