summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-10-20 10:52:09 -0400
committerJon Gjengset2015-10-20 10:52:09 -0400
commit30c76395317078520b2a56c0edd20ec785c301b4 (patch)
tree4a953a3501265683a3ab5286ba1f84c1c98f27a2
downloadaur-30c76395317078520b2a56c0edd20ec785c301b4.tar.gz
Initial working version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..055b2d6aa4b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libgpuarray-git
+ pkgdesc = Library to manipulate tensors on the GPU
+ pkgver = r1226.2d21cc2
+ pkgrel = 1
+ url = https://github.com/Theano/libgpuarray
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ provides = libgpuarray
+ conflicts = libgpuarray
+ source = git+https://github.com/Theano/libgpuarray.git
+ md5sums = SKIP
+
+pkgname = libgpuarray-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f319b8389381
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0455fcacf9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
+pkgname=libgpuarray-git
+pkgver=r1226.2d21cc2
+pkgrel=1
+pkgdesc="Library to manipulate tensors on the GPU"
+arch=('any')
+url="https://github.com/Theano/libgpuarray"
+license=('MIT')
+depends=()
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/Theano/libgpuarray.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ rm -rf Build
+ mkdir Build
+ cd Build
+ cmake .. -DCMAKE_BUILD_TYPE=Release "-DCMAKE_INSTALL_PREFIX=$pkgdir/usr"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cd Build
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cd Build
+ make install
+}