summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Fry2016-01-08 17:10:04 -0800
committerTimothy Fry2016-01-08 17:10:04 -0800
commit30fc9420067b1ba7e323baa5091d51370cc88ad6 (patch)
tree543383fa46e15e7bcf74fb9d9e55e76ae23b4921
downloadaur-30fc9420067b1ba7e323baa5091d51370cc88ad6.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD72
-rw-r--r--brackets-extract.install40
3 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..458c1306d424
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 00:58:43 UTC 2016
+pkgbase = brackets-extract
+ pkgdesc = A code editor for HTML, CSS and JavaScript with Extract bundle.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://brackets.io
+ install = brackets-extract.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = prelink
+ depends = gconf
+ depends = libgcrypt15
+ depends = nodejs
+ depends = nspr
+ depends = nss
+ depends = systemd
+ optdepends = google-chrome: to enable Live Preview
+ optdepends = gnuplot: to enable node benchmarking
+ optdepends = gtk2: to enable native UI
+ optdepends = ruby: to enable LiveDevelopment Inspector
+ optdepends = desktop-file-utils: for update-desktop-database
+ optdepends = hicolor-icon-theme: for hicolor theme hierarchy
+ provides = brackets-extract=1.5
+ conflicts = brackets
+ conflicts = brackets-git
+ conflicts = brackets-bin
+ source = https://github.com/adobe/brackets/releases/download/release-1.5%2Beb4/Brackets.1.5.Extract.-bit.deb
+
+pkgname = brackets-extract
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d4dc0336a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: trtf4006 <tim@frydaho.com>
+
+pkgname=brackets-extract
+_pkgname=brackets
+pkgver=1.5
+pkgrel=1
+pkgdesc="A code editor for HTML, CSS and JavaScript with Extract bundle."
+arch=("i686" "x86_64")
+url="http://brackets.io"
+license=("MIT")
+depends=("gconf" "libgcrypt15" "nodejs" "nspr" "nss" "systemd")
+makedepends=("prelink")
+optdepends=("google-chrome: to enable Live Preview"
+ "gnuplot: to enable node benchmarking"
+ "gtk2: to enable native UI"
+ "ruby: to enable LiveDevelopment Inspector"
+ "desktop-file-utils: for update-desktop-database"
+ "hicolor-icon-theme: for hicolor theme hierarchy")
+provides=("brackets-extract=$pkgver")
+conflicts=('brackets' 'brackets-git' 'brackets-bin')
+install=$pkgname.install
+
+if [[ $CARCH == "x86_64" ]]; then
+ _arch=64
+ sha512sums=('537ad56fcf93b024c40278cfa66626d2afc8366e537287b826277196ae4a4e628c83e955cde8a8f0431dce1f24f49b031244c81128909a8e6f44f0ddfbf77f5e')
+elif [[ $CARCH == "i686" ]]; then
+ _arch=32
+sha512sums=('c8e24cae61873601864db72128385958df14ec75feb236a250d957dbdf8b2edf45cc77855807a93381244860d0f85924eaed518bb02c87dcb0ad31f3182eb145')
+fi
+
+source=("https://github.com/adobe/$_pkgname/releases/download/release-$pkgver%2Beb4/Brackets.$pkgver.Extract.$_arch-bit.deb")
+
+prepare() {
+ cd $srcdir
+
+ msg2 " -> Extracting files..."
+ tar -xf data.tar.xz
+
+ msg2 " -> Fixing executable stack..."
+ execstack -c opt/$_pkgname/Brackets
+}
+
+package() {
+ cd $srcdir
+
+ msg2 " -> Installing program..."
+
+ install -d $pkgdir/opt
+ cp -r opt/$_pkgname $pkgdir/opt/$_pkgname
+
+ chmod -R a+rw $pkgdir/opt/$_pkgname/samples
+
+ install -d $pkgdir/usr/bin
+ ln -s /opt/brackets/brackets $pkgdir/usr/bin/$_pkgname
+
+ msg2 " -> Installing icons..."
+ local _icon_dir="usr/share/icons/hicolor"
+ install -d $pkgdir/$_icon_dir/scalable/apps
+ install -Dm644 $_icon_dir/scalable/apps/$_pkgname.svg $pkgdir/$_icon_dir/scalable/apps/$_pkgname.svg
+ for _icon in "opt/brackets/appshell"*.png; do
+ local _icon_size=${_icon##*/appshell}
+ install -d $pkgdir/$_icon_dir/${_icon_size%.png}x${_icon_size%.png}/apps
+ install -Dm644 $_icon $pkgdir/$_icon_dir/${_icon_size%.png}x${_icon_size%.png}/apps/$_pkgname.png
+ done
+
+ msg2 " -> Installing .desktop file..."
+ install -d $pkgdir/usr/share/applications
+ sed 's/Development/Development;/' opt/$_pkgname/$_pkgname.desktop > $pkgdir/usr/share/applications/$_pkgname.desktop
+
+ msg2 " -> Installing license..."
+ install -Dm755 usr/share/doc/$_pkgname/copyright $pkgdir/usr/share/licenses/$_pkgname/copyright
+}
diff --git a/brackets-extract.install b/brackets-extract.install
new file mode 100644
index 000000000000..fc1bfdcbe75a
--- /dev/null
+++ b/brackets-extract.install
@@ -0,0 +1,40 @@
+post_install() {
+ if [ ! -f /opt/brackets/libnss3.so.1d ]; then
+ ln -s /usr/lib/libnss3.so ${pkgdir}/opt/brackets/libnss3.so.1d
+ fi
+ if [ ! -f /opt/brackets/libnssutil3.so.1d ]; then
+ ln -s /usr/lib/libnssutil3.so ${pkgdir}/opt/brackets/libnssutil3.so.1d
+ fi
+ if [ ! -f /opt/brackets/libnspr4.so.0d ]; then
+ ln -s /usr/lib/libnspr4.so ${pkgdir}/opt/brackets/libnspr4.so.0d
+ fi
+ if [ ! -f /opt/brackets/libplc4.so.0d ]; then
+ ln -s /usr/lib/libplc4.so ${pkgdir}/opt/brackets/libplc4.so.0d
+ fi
+ if [ ! -f /opt/brackets/libsmime3.so.1d ]; then
+ ln -s /usr/lib/libsmime3.so ${pkgdir}/opt/brackets/libsmime3.so.1d
+ fi
+ if [ ! -f /opt/brackets/libssl3.so.1d ]; then
+ ln -s /usr/lib/libssl3.so /opt/brackets/libssl3.so.1d
+ fi
+ if [ ! -f /opt/brackets/libplds4.so.0d ]; then
+ ln -s /usr/lib/libplds4.so /opt/brackets/libplds4.so.0d
+ fi
+ if [ ! -f /opt/brackets/libudev.so.0 ]; then
+ ln -s /usr/lib/libudev.so /opt/brackets/libudev.so.0
+ fi
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+ rm -rf /opt/brackets
+}