summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Heinz2021-05-24 14:06:30 -0300
committerGustavo Heinz2021-05-24 14:12:39 -0300
commit311981f75aec78cbbe1fd8057070fd7e2093a809 (patch)
tree45db4b01d2fa1bcc904faa2b7587c62f7a357004
parent8a9276385f76db4ee799888e782f8522676939b2 (diff)
downloadaur-311981f75aec78cbbe1fd8057070fd7e2093a809.tar.gz
baresip: update 1.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--baresip-flags.patch20
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebd43e6a7447..1af7246626b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = baresip
pkgdesc = portable and modular SIP User-Agent with audio and video support
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = http://www.creytiv.com/baresip.html
arch = i686
arch = x86_64
@@ -46,10 +46,10 @@ pkgbase = baresip
optdepends = spandsp: (g722, g726,plc modules)
optdepends = speexdsp: (speex_aec, speex_pp modules)
optdepends = v4l-utils: (v4l2 module)
- source = baresip-1.0.0.tar.gz::https://github.com/alfredh/baresip/archive/v1.0.0.tar.gz
+ source = baresip-1.1.0.tar.gz::https://github.com/baresip/baresip/archive/v1.1.0.tar.gz
source = baresip-flags.patch
- sha256sums = 7b008c0a5b4fccfa0a4003f86dc4aaafeaabbdd259ece4757898e9cb5f04fdcf
- sha256sums = 60b43559bfc00a23f023b80dbc8c7a0600f607e45bc8ba8ef6a786e583cc5d08
+ sha256sums = f9230b27c4a62f31223847bc485c51f3d960f8a09f36998dedb73358e1784b4e
+ sha256sums = 43835240d0cffd2754b7dc36f62340b2fccf5966a3e4b81f0a179428f607b914
pkgname = baresip
diff --git a/PKGBUILD b/PKGBUILD
index d9645d79e209..5ab5c7e17591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Dmitrij D. Czarkoff <czarkoff at gmail dot com>
pkgname=baresip
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="portable and modular SIP User-Agent with audio and video support"
arch=('i686' 'x86_64' 'armv6h')
url="http://www.creytiv.com/baresip.html"
@@ -30,10 +30,10 @@ optdepends=('alsa-lib: (alsa module)'
'speexdsp: (speex_aec, speex_pp modules)'
'v4l-utils: (v4l2 module)')
makedepends=(${optdepends[@]/%:*/})
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/alfredh/baresip/archive/v${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/baresip/baresip/archive/v${pkgver}.tar.gz"
"baresip-flags.patch")
-sha256sums=('7b008c0a5b4fccfa0a4003f86dc4aaafeaabbdd259ece4757898e9cb5f04fdcf'
- '60b43559bfc00a23f023b80dbc8c7a0600f607e45bc8ba8ef6a786e583cc5d08')
+sha256sums=('f9230b27c4a62f31223847bc485c51f3d960f8a09f36998dedb73358e1784b4e'
+ '43835240d0cffd2754b7dc36f62340b2fccf5966a3e4b81f0a179428f607b914')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/baresip-flags.patch b/baresip-flags.patch
index a21af1e92b17..5542d149f429 100644
--- a/baresip-flags.patch
+++ b/baresip-flags.patch
@@ -1,6 +1,8 @@
---- a/Makefile 2019-12-01 08:11:12.544634301 -0500
-+++ b/Makefile 2019-12-01 08:15:27.660902785 -0500
-@@ -192,7 +192,7 @@
+diff --git a/Makefile b/Makefile
+index 0a14121e..b2e4491c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -230,7 +230,7 @@ Makefile: mk/*.mk $(MOD_MK) $(LIBRE_MK)
$(SHARED): $(LIB_OBJS)
@echo " LD $@"
@@ -9,7 +11,7 @@
$(STATICLIB): $(LIB_OBJS)
@echo " AR $@"
-@@ -217,7 +217,7 @@
+@@ -255,7 +255,7 @@ libbaresip.pc:
$(BIN): $(APP_OBJS)
@echo " LD $@"
@@ -18,7 +20,7 @@
-L$(LIBRE_SO) -lre $(LIBS) -o $@
-@@ -236,7 +236,7 @@
+@@ -274,7 +274,7 @@ test: $(TEST_BIN)
$(TEST_BIN): $(STATICLIB) $(TEST_OBJS) $(TEST_MODULES)
@echo " LD $@"
@@ -27,9 +29,11 @@
-L$(LIBRE_SO) -L. \
-l$(PROJECT) -lre $(LIBS) $(TEST_LIBS) -o $@
---- a/mk/mod.mk 2019-12-01 08:11:12.547967675 -0500
-+++ b/mk/mod.mk 2019-12-01 08:12:51.572484780 -0500
-@@ -33,7 +33,7 @@
+diff --git a/mk/mod.mk b/mk/mod.mk
+index 5408031b..f85fd23b 100644
+--- a/mk/mod.mk
++++ b/mk/mod.mk
+@@ -38,7 +38,7 @@ ifeq ($(STATIC),)
$(MOD)$(MOD_SUFFIX): $($(MOD)_OBJS)
@echo " LD [M] $@"