summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-11-14 23:20:55 +0100
committerhaawda2021-11-14 23:20:55 +0100
commit31435fd9237a28a510ce5c517de484603a4516bf (patch)
tree30561a5eda00ab43bf2131db7f615c2601a83683
parent176a5883057025bd18695ede5abd32cc67a3d760 (diff)
downloadaur-31435fd9237a28a510ce5c517de484603a4516bf.tar.gz
fix latest upstream commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--null.patch22
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d7ead4a2ad4..4c7cbf653d1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = abiword-git
pkgdesc = Fully-featured word processor from official gnome gitlab mirror
- pkgver = 3.1.0.20710.31713138f
+ pkgver = 3.1.0.20711.857cd86de
pkgrel = 1
epoch = 1
url = http://www.abisource.com
@@ -35,8 +35,10 @@ pkgbase = abiword-git
source = git+https://gitlab.gnome.org/World/AbiWord.git
source = aiksaurus-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/aiksaurus-plugin.m4?h=packages/abiword
source = command-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/command-plugin.m4?h=packages/abiword
+ source = null.patch
sha256sums = SKIP
sha256sums = 5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1
sha256sums = 2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be
+ sha256sums = e1527f5300e177549c64311d84ef76d0a63275b83ee7150213b38a63b5065063
pkgname = abiword-git
diff --git a/PKGBUILD b/PKGBUILD
index c58fd7127af5..6c2c232504b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=abiword-git
-pkgver=3.1.0.20710.31713138f
+pkgver=3.1.0.20711.857cd86de
pkgrel=1
epoch=1
pkgdesc="Fully-featured word processor from official gnome gitlab mirror"
@@ -19,10 +19,11 @@ provides=('abiword' 'abiword-plugins')
conflicts=('abiword' 'abiword-plugins')
source=("git+https://gitlab.gnome.org/World/AbiWord.git"
'aiksaurus-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/aiksaurus-plugin.m4?h=packages/abiword'
- 'command-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/command-plugin.m4?h=packages/abiword')
+ 'command-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/command-plugin.m4?h=packages/abiword' null.patch)
sha256sums=('SKIP'
'5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1'
- '2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be')
+ '2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
+ 'e1527f5300e177549c64311d84ef76d0a63275b83ee7150213b38a63b5065063')
pkgver() {
cd AbiWord
@@ -40,6 +41,7 @@ prepare() {
# Generate m4 file for configure
find plugins -name plugin.m4 | xargs cat > plugin-list.m4
+ git apply "$srcdir"/null.patch
}
build() {
diff --git a/null.patch b/null.patch
new file mode 100644
index 000000000000..855ffb4ed6a7
--- /dev/null
+++ b/null.patch
@@ -0,0 +1,22 @@
+diff --git a/plugins/command/xp/AbiCommand.cpp b/plugins/command/xp/AbiCommand.cpp
+index c22061b87..4c7217582 100644
+--- a/plugins/command/xp/AbiCommand.cpp
++++ b/plugins/command/xp/AbiCommand.cpp
+@@ -204,7 +204,7 @@ AbiCommand::AbiCommand (void) :
+ m_sErrorFile ("")
+ {
+ m_pApp = XAP_App::getApp ();
+- m_pApp->getGraphicsFactory()->registerAsDefault(GRID_CAIRO_nullptr,true);
++ m_pApp->getGraphicsFactory()->registerAsDefault(GRID_CAIRO_NULL,true);
+ m_pApp->setNoGUI(true);
+
+ }
+@@ -224,7 +224,7 @@ AbiCommand::AbiCommand (bool bAbiCollab) :
+ m_sErrorFile ("")
+ {
+ m_pApp = XAP_App::getApp ();
+- m_pApp->getGraphicsFactory()->registerAsDefault(GRID_CAIRO_nullptr,true);
++ m_pApp->getGraphicsFactory()->registerAsDefault(GRID_CAIRO_NULL,true);
+ m_pApp->setDisableDoubleBuffering(true);
+ }
+