summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-07-21 19:42:23 +0200
committerMichel Zou2023-07-21 19:42:23 +0200
commit31764284dea5f5ba6a29b6155a11e168261aae48 (patch)
tree8749b741e0c27f372260d895dfb1ea0d8cdbc524
parent5aabae5e4b9f7c5e8529a0f834c50f6149b71b08 (diff)
downloadaur-31764284dea5f5ba6a29b6155a11e168261aae48.tar.gz
23.1.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4be895e66763..2d815b47d37c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-mesa
pkgdesc = An open-source implementation of the OpenGL specification (mingw-w64)
- pkgver = 23.0.0
+ pkgver = 23.1.4
pkgrel = 1
url = https://www.mesa3d.org/
arch = any
@@ -15,15 +15,17 @@ pkgbase = mingw-w64-mesa
options = staticlibs
options = !strip
options = !buildflags
- source = https://mesa.freedesktop.org/archive/mesa-23.0.0.tar.xz
- source = https://mesa.freedesktop.org/archive/mesa-23.0.0.tar.xz.sig
+ source = https://mesa.freedesktop.org/archive/mesa-23.1.4.tar.xz
+ source = https://mesa.freedesktop.org/archive/mesa-23.1.4.tar.xz.sig
+ source = https://github.com/mesonbuild/meson/archive/refs/tags/1.0.1.tar.gz
validpgpkeys = 8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D
validpgpkeys = 946D09B5E4C9845E63075FF1D961C596A7203456
validpgpkeys = E3E8F480C52ADD73B278EE78E1ECBE07D7D70895
validpgpkeys = A5CC9FEC93F2F837CB044912336909B6B25FADFA
validpgpkeys = 71C4B75620BC75708B4BDB254C95FAAB3EB073EC
validpgpkeys = 57551DE15B968F6341C248F68D8E31AFC32428A6
- sha256sums = 01f3cff3763f09e0adabcb8011e4aebc6ad48f6a4dd4bae904fe918707d253e4
+ sha256sums = 7261a17fb94867e3dc5a90d8a1f100fa04b0cbbde51d25302c0872b5e9a10959
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = mingw-w64-mesa
diff --git a/PKGBUILD b/PKGBUILD
index 5ca78f599b6d..6d02a4d603e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-mesa
-pkgver=23.0.0
+pkgver=23.1.4
pkgrel=1
pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
arch=('any')
@@ -14,9 +14,10 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
'A5CC9FEC93F2F837CB044912336909B6B25FADFA' # Juan A. Suarez Romero <jasuarez@igalia.com>
'71C4B75620BC75708B4BDB254C95FAAB3EB073EC' # Dylan Baker <dylan@pnwbakers.com>
'57551DE15B968F6341C248F68D8E31AFC32428A6') # Eric Engestrom <eric@engestrom.ch>
-source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig})
-sha256sums=('01f3cff3763f09e0adabcb8011e4aebc6ad48f6a4dd4bae904fe918707d253e4'
- 'SKIP')
+source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
+ https://github.com/mesonbuild/meson/archive/refs/tags/1.0.1.tar.gz)
+sha256sums=('7261a17fb94867e3dc5a90d8a1f100fa04b0cbbde51d25302c0872b5e9a10959'
+ 'SKIP' 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -26,6 +27,8 @@ prepare () {
build() {
cd "${srcdir}"/mesa-${pkgver}
+ # https://github.com/mesonbuild/meson/issues/11806
+ export PYTHONPATH="${srcdir}/meson-1.0.1"
for _arch in ${_architectures}; do
${_arch}-meson build-${_arch} -Dgallium-drivers=swrast,zink -Dvulkan-drivers=swrast -Db_lto=false -Degl=disabled -Dshared-glapi=enabled -Dgles1=enabled -Dgles2=enabled -Dosmesa=true -Dvulkan-icd-dir=bin --includedir=include/mesa
ninja -C build-${_arch} ${MAKEFLAGS}