summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2017-06-27 17:04:10 -0400
committerKartik Mohta2017-06-27 17:04:10 -0400
commit323bfd37e231e5af0382973fd1c56c179a9f4374 (patch)
treefad1936c489ca62bccefa7d6d943224836469e6e
parentf9140cc53a2fc5148588e9a214f01b51fbcc31c0 (diff)
downloadaur-323bfd37e231e5af0382973fd1c56c179a9f4374.tar.gz
Fully separate into Python 2 and 3 packages
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 10 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f60c3f8298c..dc4df6082d5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,17 @@
pkgbase = python-wstool
pkgdesc = workspace multi-SCM commands
pkgver = 0.1.13
- pkgrel = 2
+ pkgrel = 3
url = http://wiki.ros.org/wstool
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/w/wstool/wstool-0.1.13.tar.gz
- md5sums = 7e41a0e4f92389a6b4e115c80dd5cf10
-
-pkgname = python-wstool
- depends =
depends = python
depends = python-vcstools
depends = python-yaml
conflicts = python2-wstool
+ source = https://files.pythonhosted.org/packages/source/w/wstool/wstool-0.1.13.tar.gz
+ md5sums = 7e41a0e4f92389a6b4e115c80dd5cf10
-pkgname = python2-wstool
- depends =
- depends = python2
- depends = python2-vcstools
- depends = python2-yaml
- conflicts = python-wstool
+pkgname = python-wstool
diff --git a/PKGBUILD b/PKGBUILD
index d6b615e72c53..33d06d59e5bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,26 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
pkgbase=('python-wstool')
-pkgname=('python-wstool' 'python2-wstool')
+pkgname=('python-wstool')
_module='wstool'
pkgver='0.1.13'
-pkgrel=2
+pkgrel=3
pkgdesc="workspace multi-SCM commands"
url="http://wiki.ros.org/wstool"
-depends=()
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python' 'python-vcstools' 'python-yaml')
+conflicts=('python2-wstool')
+makedepends=('python-setuptools')
license=('BSD')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/w/wstool/wstool-${pkgver}.tar.gz")
md5sums=('7e41a0e4f92389a6b4e115c80dd5cf10')
-prepare() {
- cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
-}
-
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py build
}
-package_python-wstool() {
- depends+=('python' 'python-vcstools' 'python-yaml')
- conflicts=('python2-wstool')
+package() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
-
-package_python2-wstool() {
- depends+=('python2' 'python2-vcstools' 'python2-yaml')
- conflicts=('python-wstool')
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}