summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbanbanchs2016-12-18 10:23:52 +0800
committerbanbanchs2016-12-18 10:23:52 +0800
commit324473dd58b434eda06ce6e93edc7fc9c87edbb4 (patch)
treead3fdd6f57ddb91944566c7db82d43cdca5e9cad
downloadaur-324473dd58b434eda06ce6e93edc7fc9c87edbb4.tar.gz
Add jid-bin
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ad8835c6da4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = jid-bin
+ pkgdesc = Json incremental digger
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/simeji/jid
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ source = https://github.com/simeji/jid/releases/download/0.6.2/jid_linux_amd64.zip
+ sha256sums = 17bf8657edd74e570286018d86a4a8835ced0e9ea1ea79b5284f9caa9355275f
+
+pkgname = jid-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a384ade83ce6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: banbanchs <memory.silentvoyage@gmail.com>
+
+pkgname=jid-bin
+_pkgname=jid
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Json incremental digger"
+url="https://github.com/simeji/jid"
+arch=("x86_64")
+license=("MIT")
+provides=()
+conflicts=()
+depends=("glibc")
+source=("https://github.com/simeji/jid/releases/download/${pkgver}/${_pkgname}_linux_amd64.zip")
+sha256sums=('17bf8657edd74e570286018d86a4a8835ced0e9ea1ea79b5284f9caa9355275f')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 "${srcdir}/${_pkgname}_linux_amd64" "$pkgdir/usr/bin/${_pkgname}"
+}
+