summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdwin Peters2018-04-24 14:04:36 +1000
committerEdwin Peters2018-04-24 14:04:36 +1000
commit326e6f9d5a1bf7125a539016ccd72c27d23c95b1 (patch)
tree291c8cee74b501342d4b891dbc3a10e8c1d1d4c2
downloadaur-326e6f9d5a1bf7125a539016ccd72c27d23c95b1.tar.gz
initial submission
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96c5ee1b4a69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-reedsolomon
+ pkgdesc = Pure-Python Reed Solomon encoder/decoder
+ pkgver = c9ec28a
+ pkgrel = 1
+ url = https://github.com/tomerfiliba/reedsolomon
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ optdepends = cython
+ source = git+https://github.com/tomerfiliba/reedsolomon.git
+ sha256sums = SKIP
+
+pkgname = python-reedsolomon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9b98319af9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Edwin Peters <slimed13 at hotmail dot com>
+
+pkgname=python-reedsolomon
+pkgver=c9ec28a
+pkgrel=1
+pkgdesc="Pure-Python Reed Solomon encoder/decoder"
+arch=('any')
+url="https://github.com/tomerfiliba/reedsolomon"
+license=('BSD')
+depends=('python' )
+optdepends=('cython' )
+makedepends=('python-setuptools' 'git')
+source=(git+https://github.com/tomerfiliba/reedsolomon.git)
+sha256sums=(SKIP)
+
+package() {
+ cd ${srcdir}/reedsolomon
+
+ # ignores any LDFLAGS set in makepkg.conf
+ unset LDFLAGS
+
+ python ./setup.py install --root=${pkgdir}
+
+}
+