summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2023-10-01 20:23:01 +0000
committerMarco Pompili2023-10-01 20:23:01 +0000
commit327405bcfeeaae3a95c0c578e8562a97d92f4aef (patch)
tree40e05cda5b7fdaa151378aa0880b9986f2bd1f96
parente94ffea7fff37d55f6ce1c65e6c1e7db87c9fb8a (diff)
downloadaur-327405bcfeeaae3a95c0c578e8562a97d92f4aef.tar.gz
Version 0.12.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--fix-libsndfile-error.patch28
3 files changed, 9 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b7e76eca8a3..377111c423c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openframeworks
pkgdesc = An open source C++ toolkit for creative coding.
- pkgver = 0.11.2
- pkgrel = 3
+ pkgver = 0.12.0
+ pkgrel = 1
url = http://openframeworks.cc/
install = openframeworks.install
arch = x86_64
@@ -34,10 +34,8 @@ pkgbase = openframeworks
optdepends = xterm
options = !strip
source = of-make-workspace
- source = https://openframeworks.cc/versions/v0.11.2/of_v0.11.2_linux64gcc6_release.tar.gz
- source = https://gist.githubusercontent.com/kerrickstaley/7f8c65a27a1f4e79a942235b87c1f0c0/raw/28f7d0dd94237076f72b8eaf2e009831d7d61a5d/fix-libsndfile-error.patch
+ source = https://github.com/openframeworks/openFrameworks/releases/download/0.12.0/of_v0.12.0_linux64gcc6_release.tar.gz
sha256sums = b4fc38288595df566f770018d871970fb13fb2ad4af7e9e5cddc60288f338806
- sha256sums = 9907beae6c786751470f5a55f1273280f3c240b4a93ce0c4a32c4a62b401470c
- sha256sums = 67693b69e2c36861d14ce9fa57b6855898c48fa4ed90e6aa14d7ce3a779b6110
+ sha256sums = 942cd299c903e0aeea5f05e429ab813702e0ba4f99a5a3d0e7c21e61be9b3b2b
pkgname = openframeworks
diff --git a/PKGBUILD b/PKGBUILD
index c6928209b482..18b419be9a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
pkgname=openframeworks
-pkgver=0.11.2
-pkgrel=3
+pkgver=0.12.0
+pkgrel=1
pkgdesc="An open source C++ toolkit for creative coding."
url="http://openframeworks.cc/"
arch=('x86_64')
@@ -15,12 +15,10 @@ options=(!strip)
install=openframeworks.install
source=(
"of-make-workspace"
- "https://openframeworks.cc/versions/v${pkgver}/of_v${pkgver}_linux64gcc6_release.tar.gz"
- "https://gist.githubusercontent.com/kerrickstaley/7f8c65a27a1f4e79a942235b87c1f0c0/raw/28f7d0dd94237076f72b8eaf2e009831d7d61a5d/fix-libsndfile-error.patch"
+ "https://github.com/openframeworks/openFrameworks/releases/download/0.12.0/of_v0.12.0_linux64gcc6_release.tar.gz"
)
sha256sums=('b4fc38288595df566f770018d871970fb13fb2ad4af7e9e5cddc60288f338806'
- '9907beae6c786751470f5a55f1273280f3c240b4a93ce0c4a32c4a62b401470c'
- '67693b69e2c36861d14ce9fa57b6855898c48fa4ed90e6aa14d7ce3a779b6110')
+ '942cd299c903e0aeea5f05e429ab813702e0ba4f99a5a3d0e7c21e61be9b3b2b')
_name="of_v${pkgver}_linux64gcc6_release"
@@ -29,6 +27,7 @@ prepare() {
export OF_ROOT=${srcdir}/${_name}
export LC_ALL=C
+ export CXXFLAGS="-Wall -Wno-error -Wno-format-security"
ARCH=$(uname -m)
@@ -37,10 +36,6 @@ prepare() {
else
LIBSPATH=linux
fi
-
- msg2 "Apply patch to fix libsndfile error..."
- cd ${srcdir}/${_name}
- patch -p1 < ${srcdir}/fix-libsndfile-error.patch
}
build() {
diff --git a/fix-libsndfile-error.patch b/fix-libsndfile-error.patch
deleted file mode 100644
index ceacc8f03a5b..000000000000
--- a/fix-libsndfile-error.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/libs/openFrameworks/sound/ofOpenALSoundPlayer.cpp b/libs/openFrameworks/sound/ofOpenALSoundPlayer.cpp
-index 71caf42d8..39146d7d6 100644
---- a/libs/openFrameworks/sound/ofOpenALSoundPlayer.cpp
-+++ b/libs/openFrameworks/sound/ofOpenALSoundPlayer.cpp
-@@ -7,7 +7,6 @@
- #include "glm/common.hpp"
- #include "ofLog.h"
- #include "ofEvents.h"
--#include <sndfile.h>
-
- #if defined (TARGET_OF_IOS) || defined (TARGET_OSX)
- #include <OpenAL/al.h>
-diff --git a/libs/openFrameworks/sound/ofOpenALSoundPlayer.h b/libs/openFrameworks/sound/ofOpenALSoundPlayer.h
-index 042f7b354..80df4f90c 100644
---- a/libs/openFrameworks/sound/ofOpenALSoundPlayer.h
-+++ b/libs/openFrameworks/sound/ofOpenALSoundPlayer.h
-@@ -12,10 +12,7 @@ typedef unsigned int ALuint;
-
- #include "kiss_fft.h"
- #include "kiss_fftr.h"
--
--
--
--typedef struct SNDFILE_tag SNDFILE ;
-+#include <sndfile.h>
-
-
- #ifdef OF_USING_MPG123