summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriRet2021-03-12 17:08:54 +0700
committeriRet2021-03-12 17:08:54 +0700
commit329aaa54d6a6eb6d59a32263c926fe2154898c89 (patch)
treea8027914d66baf4c0186168e48329e7972c06b5a
parent523c2548025028d154957df18312ef29cdbd19c7 (diff)
downloadaur-329aaa54d6a6eb6d59a32263c926fe2154898c89.tar.gz
Updated to 2.16
-rw-r--r--PKGBUILD11
-rwxr-xr-xsetup.py10
2 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 198bd2bbee49..0ddd23dc3916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Maintainer: iRet <iRet at a22 dot in>
+# Contributor: XavierCLL <xavier.corredor.llano at gmail dot com>
pkgname=spotify-ripper
-pkgver=2.14
+pkgver=2.16
pkgrel=1
pkgdesc='Command-line ripper for Spotify, with a workaround for playlist emptying'
arch=('any')
@@ -14,12 +15,12 @@ optdepends=('flac: Rip songs to lossless FLAC encoding' 'opus-tools: Rip songs t
makedepends=('python-setuptools' 'libspotify')
source=("https://github.com/scaronni/spotify-ripper/archive/${pkgver}.tar.gz"
"setup.py" "requirements.txt")
-md5sums=('347411bf137546432443f143f21221bd'
- '2c3e897ce5cf74e0cf2db5cbf1890371'
+md5sums=('0d0931086d5ed6a18c7559b44a377eaa'
+ 'a7dc7a6632aa88143eec50545694f6f0'
'433ec722cffccd32c7e31807262f1128')
package() {
- cd $pkgname-*
+ cd $pkgname-$pkgver
# fix imports
cp ../setup.py .
diff --git a/setup.py b/setup.py
index f78c0eed64a6..3e3c8b52e3f6 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,8 @@ import os
def create_default_dir():
- default_dir = os.path.normpath(os.path.realpath((os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
+ default_dir = os.path.normpath(os.path.realpath(
+ (os.path.join(os.path.expanduser("~"), ".spotify-ripper"))))
if not os.path.exists(default_dir):
print("Creating default settings directory: " + default_dir)
os.makedirs(default_dir.encode("utf-8"))
@@ -16,11 +17,12 @@ def _read(fn):
path = os.path.join(os.path.dirname(__file__), fn)
return open(path).read()
+
setup(
name='spotify-ripper',
- version='2.14',
+ version='2.16',
packages=find_packages(exclude=["tests"]),
- #scripts=['spotify_ripper/main.py'],
+ # scripts=['spotify_ripper/main.py'],
include_package_data=True,
zip_safe=False,
@@ -53,7 +55,7 @@ setup(
license='MIT',
keywords="spotify ripper mp3 ogg vorbis flac opus acc mp4 m4a",
url='https://github.com/scaronni/spotify-ripper',
- download_url='https://github.com/scaronni/spotify-ripper/tarball/2.14',
+ download_url='https://github.com/scaronni/spotify-ripper/tarball/2.16',
classifiers=[
'Topic :: Multimedia :: Sound/Audio',
'Topic :: Multimedia :: Sound/Audio :: Capture/Recording',