summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 16:35:00 +0200
committerMaxime Gauduin2017-05-01 16:35:00 +0200
commit32afdad293125bf50d29ff5e9c8c8572cf8824bb (patch)
tree56083244896616efa16d8aad9a24d87f40fafd77
downloadaur-32afdad293125bf50d29ff5e9c8c8572cf8824bb.tar.gz
Add pantheon-music-git
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD67
-rw-r--r--mesa-demos-conflict.patch31
-rw-r--r--noise-install-dirs.patch42
4 files changed, 194 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9a694675a9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,54 @@
+# Generated by mksrcinfo v8
+# Mon May 1 14:35:00 UTC 2017
+pkgbase = pantheon-music-git
+ pkgdesc = The Pantheon Music Player
+ pkgver = r2949.5385ace5
+ pkgrel = 1
+ url = https://github.com/elementary/music
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = granite-git
+ makedepends = intltool
+ makedepends = vala
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gst-plugins-base-libs
+ depends = gstreamer
+ depends = gtk3
+ depends = json-glib
+ depends = libaccounts-glib
+ depends = libgda
+ depends = libgee
+ depends = libgpod
+ depends = libgsignon-glib
+ depends = libpeas
+ depends = libsoup
+ depends = pango
+ depends = taglib
+ depends = zeitgeist
+ depends = libgranite.so
+ optdepends = gst-plugins-base: "Base" plugin libraries
+ optdepends = gst-plugins-good: "Good" plugin libraries
+ optdepends = gst-plugins-bad: "Bad" plugin libraries
+ optdepends = gst-plugins-ugly: "Ugly" plugin libraries
+ optdepends = gst-libav: Libav plugin
+ provides = pantheon-music
+ conflicts = noise
+ conflicts = noise-player
+ conflicts = pantheon-music
+ replaces = noise-player-bzr
+ source = pantheon-music::git+https://github.com/elementary/music.git
+ source = mesa-demos-conflict.patch
+ source = noise-install-dirs.patch
+ sha256sums = SKIP
+ sha256sums = 9135fe677b0d61778a624ba211b545eb861468b500cfd161469aa28139ab1296
+ sha256sums = d0ebc710a742d942e04a8df61d91dd75ae4b2aeafe7fece08f1fbc90c507f1df
+
+pkgname = pantheon-music-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e77a67e2d85b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-music-git
+pkgver=r2949.5385ace5
+pkgrel=1
+pkgdesc='The Pantheon Music Player'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/music'
+license=('GPL3')
+depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gst-plugins-base-libs'
+ 'gstreamer' 'gtk3' 'json-glib' 'libaccounts-glib' 'libgda' 'libgee'
+ 'libgpod' 'libgsignon-glib' 'libpeas' 'libsoup' 'pango' 'taglib'
+ 'zeitgeist'
+ 'libgranite.so')
+makedepends=('cmake' 'git' 'gobject-introspection' 'granite-git' 'intltool'
+ 'vala')
+optdepends=('gst-plugins-base: "Base" plugin libraries'
+ 'gst-plugins-good: "Good" plugin libraries'
+ 'gst-plugins-bad: "Bad" plugin libraries'
+ 'gst-plugins-ugly: "Ugly" plugin libraries'
+ 'gst-libav: Libav plugin')
+provides=('pantheon-music')
+conflicts=('noise' 'noise-player' 'pantheon-music')
+replaces=('noise-player-bzr')
+source=('pantheon-music::git+https://github.com/elementary/music.git'
+ 'mesa-demos-conflict.patch'
+ 'noise-install-dirs.patch')
+sha256sums=('SKIP'
+ '9135fe677b0d61778a624ba211b545eb861468b500cfd161469aa28139ab1296'
+ 'd0ebc710a742d942e04a8df61d91dd75ae4b2aeafe7fece08f1fbc90c507f1df')
+
+pkgver() {
+ cd pantheon-music
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd pantheon-music
+
+ patch -Np1 -i ../mesa-demos-conflict.patch
+ patch -Np1 -i ../noise-install-dirs.patch
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd pantheon-music/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DGSETTINGS_COMPILE='FALSE'
+ make -j1
+}
+
+package() {
+ cd pantheon-music/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/mesa-demos-conflict.patch b/mesa-demos-conflict.patch
new file mode 100644
index 000000000000..0c1b99c57dd0
--- /dev/null
+++ b/mesa-demos-conflict.patch
@@ -0,0 +1,31 @@
+diff -rupN noise-0.4.orig/data/org.pantheon.noise.desktop.in.in noise-0.4/data/org.pantheon.noise.desktop.in.in
+--- noise-0.4.orig/data/org.pantheon.noise.desktop.in.in 2016-08-12 12:42:36.415710999 +0200
++++ noise-0.4/data/org.pantheon.noise.desktop.in.in 2016-08-12 12:46:39.418412632 +0200
+@@ -3,7 +3,7 @@ Type=Application
+ _Name=@APP_NAME@
+ _GenericName=Music Player
+ _Comment=Listen to music
+-Exec=noise %U
++Exec=pantheon-music %U
+ Icon=multimedia-audio-player
+ Terminal=false
+ Categories=Audio;Music;Player;AudioVideo;GNOME;GTK;
+@@ -15,5 +15,5 @@ X-PulseAudio-Properties=media.role=music
+ Actions=AboutDialog;
+
+ [Desktop Action AboutDialog]
+-Exec=noise --about
++Exec=pantheon-music --about
+ _Name=About @APP_NAME@
+diff -rupN noise-0.4.orig/src/CMakeLists.txt noise-0.4/src/CMakeLists.txt
+--- noise-0.4.orig/src/CMakeLists.txt 2016-08-12 12:42:36.425710687 +0200
++++ noise-0.4/src/CMakeLists.txt 2016-08-12 12:45:25.250582352 +0200
+@@ -88,7 +88,7 @@ vala_precompile (CLIENT_VALA_C ${SRC_TAR
+ ${CLIENT_VAPI}
+ )
+
+-set (EXEC_NAME ${SRC_TARGET})
++set (EXEC_NAME pantheon-music)
+
+ add_definitions (${DEPS_CFLAGS})
+ link_directories (${DEPS_LIBRARY_DIRS})
diff --git a/noise-install-dirs.patch b/noise-install-dirs.patch
new file mode 100644
index 000000000000..21050a8abba4
--- /dev/null
+++ b/noise-install-dirs.patch
@@ -0,0 +1,42 @@
+diff -rupN noise-0.3.1.orig/CMakeLists.txt noise-0.3.1/CMakeLists.txt
+--- noise-0.3.1.orig/CMakeLists.txt 2015-08-30 14:03:02.563699740 +0200
++++ noise-0.3.1/CMakeLists.txt 2015-08-30 14:05:57.528197582 +0200
+@@ -13,11 +13,10 @@ set (VERSION "0.3.1")
+ set (VERSION_INFO "Stable Release")
+
+ include (GNUInstallDirs)
+-set (DATADIR ${CMAKE_INSTALL_PREFIX}/share)
++set (DATADIR ${CMAKE_INSTALL_FULL_DATADIR})
+ set (PKG_DATADIR ${DATADIR}/${CMAKE_PROJECT_NAME})
+ set (ICON_DIR ${DATADIR}/${CMAKE_PROJECT_NAME}/icons)
+-set (PLUGIN_DIR_UNPREFIXED ${CMAKE_INSTALL_LIBDIR}/${CMAKE_PROJECT_NAME}/plugins)
+-set (PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/${PLUGIN_DIR_UNPREFIXED})
++set (PLUGIN_DIR ${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}/plugins)
+
+ add_definitions ("-DGETTEXT_PACKAGE=\"${GETTEXT_PACKAGE}\"")
+
+diff -rupN noise-0.3.1.orig/core/noise-core.pc.cmake noise-0.3.1/core/noise-core.pc.cmake
+--- noise-0.3.1.orig/core/noise-core.pc.cmake 2015-08-30 14:03:02.563699740 +0200
++++ noise-0.3.1/core/noise-core.pc.cmake 2015-08-30 14:03:14.083336997 +0200
+@@ -1,12 +1,12 @@
+ prefix=@PREFIX@
+-exec_prefix=@DOLLAR@{prefix}
+-libdir=@DOLLAR@{prefix}/@CMAKE_INSTALL_LIBDIR@
+-includedir=@DOLLAR@{prefix}/@CMAKE_INSTALL_INCLUDEDIR@/
+-plugindir=@DOLLAR@{prefix}/@PLUGIN_DIR_UNPREFIXED@
+-
++exec_prefix=@PREFIX@
++libdir=@CMAKE_INSTALL_FULL_LIBDIR@
++includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
++plugindir=@PLUGIN_DIR@
++
+ Name: Noise
+-Description: Noise headers
+-Version: @VERSION@
++Description: Noise headers
++Version: @VERSION@
+ Libs: -lnoise-core
+ Cflags: -I@DOLLAR@{includedir}/noise-core
+-Requires: glib-2.0 gio-2.0 gee-0.8 libpeas-1.0 libpeas-gtk-1.0 gtk+-3.0 granite gstreamer-1.0 gstreamer-pbutils-1.0 gstreamer-tag-1.0
+\ No newline at end of file
++Requires: glib-2.0 gio-2.0 gee-0.8 libpeas-1.0 libpeas-gtk-1.0 gtk+-3.0 granite gstreamer-1.0 gstreamer-pbutils-1.0 gstreamer-tag-1.0