summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmartinez-mirror2021-03-21 21:32:05 -0500
committerlmartinez-mirror2021-03-21 21:34:02 -0500
commit32b2ec5989b445d24b7427e6e6ed2753d9e09a92 (patch)
tree769535382d69735272329a2725cbeeb950988056
downloadaur-32b2ec5989b445d24b7427e6e6ed2753d9e09a92.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e54156dbae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hilbish-git
+ pkgdesc = A shell written in Go and extended with Lua
+ pkgver = 0.0.12.r5.g9cc9c4a
+ pkgrel = 1
+ url = https://github.com/hilbis/hilbish
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go>=1.16
+ depends = readline
+ optdepends = lua
+ provides = hilbish
+ conflicts = hilbish
+ source = hilbish-git::git+https://github.com/hilbis/hilbish
+ sha256sums = SKIP
+
+pkgname = hilbish-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06e17926fc2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: lmartinez-mirror
+pkgname=hilbish-git
+_pkgname=${pkgname%-git}
+pkgver=0.0.12.r5.g9cc9c4a
+pkgrel=1
+pkgdesc="A shell written in Go and extended with Lua"
+arch=('x86_64')
+url="https://github.com/hilbis/hilbish"
+license=('MIT')
+depends=('readline')
+makedepends=('git' 'go>=1.16')
+optdepends=('lua')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd "$pkgname"
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\""
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 755 hilbish -t "$pkgdir/usr/bin/"
+ install -Dm 644 preload.lua -t "$pkgdir/usr/share/$_pkgname/"
+ install -Dm 644 .hilbishrc.lua -t "$pkgdir/usr/share/$_pkgname/"
+ find libs -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/$_pkgname/{}" \;
+ install -Dm 444 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 444 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}